summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroltulu2018-07-30 19:42:59 +0300
committeroltulu2018-07-30 19:42:59 +0300
commited9ace5b1e65aa0aa404972a1acc3113c01951ec (patch)
tree9d7b2d7fa11f99337cf5be2a6f1ee9fe3b3d06b6
downloadaur-ukui-desktop.tar.gz
PKGBUILD .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c16c88a872f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ukui-desktop
+ pkgdesc = UKUI Masaüstü
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://ukui-desktop.org
+ arch = x86_64
+ groups = ukui
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = intltool
+ depends = gtk3
+ depends = ukwm
+ depends = startup-notification
+ source = git+https://github.com/ukui/ukui-desktop.git
+ sha256sums = SKIP
+
+pkgname = ukui-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..570a5fba946e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Cihan Alkan <cihanalk@gmail.com>
+
+pkgname=ukui-desktop
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="UKUI Masaüstü"
+url="https://ukui-desktop.org"
+arch=('x86_64')
+license=('GPL')
+depends=('gtk3' 'ukwm' 'startup-notification')
+makedepends=('gobject-introspection' 'intltool')
+optdepends=()
+groups=('ukui')
+source=("git+https://github.com/ukui/ukui-desktop.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd ${pkgname}
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd ${pkgname}
+ ./configure \
+ --prefix=/usr \
+ --disable-schemas-compile
+
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}