summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbin Larsson2021-10-17 11:16:12 +0200
committerAlbin Larsson2021-10-17 11:16:12 +0200
commitc0fd35358c4c9173c318b7c48adbf9a6cd340a20 (patch)
tree25e9cb852f025076f5672bd6ec1ce1a8b208b48c
parent81beaccf111d1a457cbeaa1ccd56fcea1abdff50 (diff)
downloadaur-c0fd35358c4c9173c318b7c48adbf9a6cd340a20.tar.gz
Make install script ignore users PATH, so it won't use pyenv Python version
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc252e42fbb1..6a7a1000dcc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,13 +21,13 @@ sha256sums=('SKIP')
build() {
cd ulauncher
- python setup.py build
+ env PATH=$(getconf PATH) python setup.py build
}
package() {
cd ulauncher
export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ env PATH=$(getconf PATH) python setup.py install --root="$pkgdir" --optimize=1 --skip-build
rm -rf "$pkgdir"/usr/share/ulauncher/preferences/{no*,src,bow*,gul*,pack*}
find $pkgdir -type d -name __pycache__ | xargs rm -rf
}