summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbin Larsson2021-08-13 20:34:47 +0200
committerAlbin Larsson2021-08-13 20:34:47 +0200
commit29690b4366c8064cd3de2f0d4e5aa462d16451a0 (patch)
tree97465fe68f9cc4e30c341a2307e81224607ba759
parentce3eee0a0c7b0f27ae6f41ebf87e492535a1c5c2 (diff)
downloadaur-29690b4366c8064cd3de2f0d4e5aa462d16451a0.tar.gz
Update package dependencies and include/install systemd service
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--ulauncher.install14
3 files changed, 49 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f668daae0045..754895f6691a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,27 +3,32 @@ pkgbase = ulauncher-git
pkgver = DEV
pkgrel = 1
url = http://ulauncher.io
+ install = ulauncher.install
arch = any
license = GPL3
+ checkdepends = desktop-file-utils
makedepends = git
makedepends = yarn
- makedepends = python-distutils-extra
makedepends = python-setuptools
+ makedepends = python-distutils-extra
depends = gobject-introspection-runtime
- depends = libappindicator-gtk3
depends = libkeybinder3
+ depends = gtk3
depends = webkit2gtk
+ depends = libnotify
+ depends = gdk-pixbuf2
depends = python-dbus
- depends = python-gobject
- depends = python-cairo
- depends = python-pyinotify
depends = python-levenshtein
- depends = python-xdg
+ depends = python-pyinotify
depends = python-websocket-client
+ depends = python-pyxdg
+ depends = python-gobject
+ depends = python-cairo
+ optdepends = libappindicator-gtk3: tray icon
+ optdepends = wmctrl: fix window focus on Wayland
provides = ulauncher
conflicts = ulauncher
source = ulauncher::git+https://github.com/Ulauncher/Ulauncher.git
sha256sums = SKIP
pkgname = ulauncher-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 48838ef72ce9..0c08b8625abb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Aleksandr Gornostal <ulauncher.app@gmail.com>
+# Maintainer: Albin Larsson <mail@albinlarsson.com>
+# Contributor: Aleksandr Gornostal <ulauncher.app@gmail.com>
# To install, run `makepkg -is`
@@ -9,12 +10,17 @@ pkgdesc='Application launcher for Linux'
arch=('any')
url="http://ulauncher.io"
license=('GPL3')
-depends=('gobject-introspection-runtime' 'libappindicator-gtk3' 'libkeybinder3' 'webkit2gtk'
- "python-"{dbus,gobject,cairo,pyinotify,levenshtein,xdg,websocket-client})
-makedepends=('git' 'yarn' "python-"{distutils-extra,setuptools})
-provides=("${pkgname%-*}")
-conflicts=("${pkgname%-*}")
+depends=('gobject-introspection-runtime' 'libkeybinder3' 'gtk3' 'webkit2gtk' 'libnotify'
+ 'gdk-pixbuf2' 'python-dbus' 'python-levenshtein' 'python-pyinotify'
+ 'python-websocket-client' 'python-pyxdg' 'python-gobject' 'python-cairo')
+makedepends=('git' 'yarn' 'python-setuptools' 'python-distutils-extra')
+checkdepends=('desktop-file-utils')
+optdepends=('libappindicator-gtk3: tray icon' 'wmctrl: fix window focus on Wayland')
+install="ulauncher.install"
+provides=("ulauncher")
+conflicts=("ulauncher")
source=("ulauncher::git+https://github.com/Ulauncher/Ulauncher.git")
+
sha256sums=('SKIP')
pkgver() {
@@ -34,10 +40,20 @@ build() {
./ul build-preferences
}
+check() {
+ cd ulauncher
+ desktop-file-validate "build/share/applications/ulauncher.desktop"
+}
+
package() {
cd ulauncher
- install -Dm644 build/share/applications/ulauncher.desktop "$pkgdir/usr/share/applications/ulauncher.desktop"
+
+ install -Dm644 "build/share/applications/ulauncher.desktop" -t \
+ "$pkgdir/usr/share/applications"
+
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "ulauncher.service" -t "$pkgdir/usr/lib/systemd/user"
rm -rf "$pkgdir"/usr/share/ulauncher/preferences/{no*,src,bow*,gul*,pack*}
find $pkgdir -type d -name __pycache__ | xargs rm -rf
}
diff --git a/ulauncher.install b/ulauncher.install
new file mode 100644
index 000000000000..6619a4bc05f6
--- /dev/null
+++ b/ulauncher.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo ""
+ echo "Enable the service:"
+ echo "systemctl --user enable --now ulauncher.service"
+ echo ""
+}
+
+post_upgrade() {
+ echo ""
+ echo "Restart the service:"
+ echo "systemctl --user daemon-reload"
+ echo "systemctl --user restart ulauncher.service"
+ echo ""
+} \ No newline at end of file