summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbin Larsson2022-03-27 18:23:09 +0200
committerAlbin Larsson2022-03-27 18:23:09 +0200
commit7b0525981e5f99cf7561d1c5a6cedbd2552b3639 (patch)
treeca2b07ba2c4d060b7e8df41a2a9a5bc749662824
parente431d678cb5c03a4c31de0e97646ce7b3aaa438b (diff)
downloadaur-7b0525981e5f99cf7561d1c5a6cedbd2552b3639.tar.gz
Update build to v6
-rw-r--r--PKGBUILD23
-rw-r--r--ulauncher.install5
2 files changed, 6 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 015072817393..bd20c1c32649 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,10 @@ pkgdesc='Application launcher for Linux'
arch=('any')
url="http://ulauncher.io"
license=('GPL3')
-depends=('gobject-introspection-runtime' 'libkeybinder3' 'gtk3' 'webkit2gtk' 'libnotify'
- 'gdk-pixbuf2' 'python-dbus' 'python-levenshtein' 'python-pyinotify'
- 'python-websocket-client' 'python-pyxdg' 'python-gobject' 'python-cairo')
-makedepends=('git' 'yarn' 'python-setuptools' 'python-distutils-extra')
+depends=('gtk3' 'webkit2gtk' 'libnotify' 'libkeybinder3' 'python-gobject' 'python-levenshtein')
+makedepends=('git' 'yarn' 'python-setuptools')
checkdepends=('desktop-file-utils')
-optdepends=('libappindicator-gtk3: tray icon' 'wmctrl: fix window focus on Wayland')
+optdepends=('libappindicator-gtk3: tray icon')
install="ulauncher.install"
provides=("ulauncher")
conflicts=("ulauncher")
@@ -23,32 +21,19 @@ source=("ulauncher::git+https://github.com/Ulauncher/Ulauncher.git")
sha256sums=('SKIP')
-pkgver() {
- cd ulauncher
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd ulauncher
- sed -i "s/%VERSION%/${pkgver%.*.*}/g" setup.py
- find -iname "*.py" | xargs sed -i 's=\(^#! */usr/bin.*\)python3 *$=\1python='
-}
-
build() {
cd ulauncher
env PATH=$(getconf PATH) python setup.py build
- ./ul build-preferences
}
check() {
cd ulauncher
- desktop-file-validate "build/share/applications/ulauncher.desktop"
+ desktop-file-validate "ulauncher.desktop"
}
package() {
cd ulauncher
export PYTHONHASHSEED=0
env PATH=$(getconf PATH) python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- rm -rf "$pkgdir"/usr/share/ulauncher/preferences/{no*,src,bow*,gul*,pack*}
find $pkgdir -type d -name __pycache__ | xargs rm -rf
}
diff --git a/ulauncher.install b/ulauncher.install
index 6619a4bc05f6..3397559a1e9d 100644
--- a/ulauncher.install
+++ b/ulauncher.install
@@ -1,14 +1,13 @@
post_install() {
echo ""
echo "Enable the service:"
- echo "systemctl --user enable --now ulauncher.service"
+ echo "systemctl --user enable --now ulauncher"
echo ""
}
post_upgrade() {
echo ""
echo "Restart the service:"
- echo "systemctl --user daemon-reload"
- echo "systemctl --user restart ulauncher.service"
+ echo "systemctl --user daemon-reload && systemctl --user restart ulauncher"
echo ""
} \ No newline at end of file