summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandr Gornostal2017-03-04 17:02:33 +0200
committerAleksandr Gornostal2017-03-04 17:05:19 +0200
commit80b0f76407e464b9b7348c9ae3fcc74168bba1de (patch)
tree973b46909589f5c1daf5a21f20d7cd942a8a49c1
parentda101b546412bd01105784c2f945ba58fc83da36 (diff)
downloadaur-80b0f76407e464b9b7348c9ae3fcc74168bba1de.tar.gz
Reverted to the original PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48c7115e96d2..6689418398ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
# Generated by mksrcinfo v8
-# Sat Mar 4 12:04:55 UTC 2017
+# Sat Mar 4 15:04:50 UTC 2017
pkgbase = ulauncher-git
pkgdesc = Application launcher for Linux
- pkgver = 2.0.30
+ pkgver = 2.0.14.r0.gbdf867f
pkgrel = 1
url = http://ulauncher.io
arch = any
license = GPL3
+ makedepends = git
+ makedepends = npm
makedepends = python2-distutils-extra
+ makedepends = python2-setuptools
depends = gobject-introspection-runtime
depends = libappindicator-gtk3
depends = libkeybinder3
@@ -20,7 +23,7 @@ pkgbase = ulauncher-git
depends = python2-xdg
provides = ulauncher
conflicts = ulauncher
- source = https://github.com/Ulauncher/Ulauncher/releases/download/2.0.30/ulauncher_2.0.30.tar.gz
+ source = ulauncher::git+https://github.com/Ulauncher/Ulauncher.git
sha256sums = SKIP
pkgname = ulauncher-git
diff --git a/PKGBUILD b/PKGBUILD
index 9eb92d1f22cd..7b8748b9a7f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# To install, run `makepkg -is`
pkgname=ulauncher-git
-pkgver=2.0.30
+pkgver=2.0.14.r0.gbdf867f
pkgrel=1
pkgdesc='Application launcher for Linux'
arch=('any')
@@ -11,20 +11,27 @@ url="http://ulauncher.io"
license=('GPL3')
depends=('gobject-introspection-runtime' 'libappindicator-gtk3' 'libkeybinder3' 'webkit2gtk'
"python2-"{dbus,gobject,pyinotify,pysqlite,levenshtein,xdg})
-makedepends=('python2-distutils-extra')
+makedepends=('git' 'npm' "python2-"{distutils-extra,setuptools})
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("https://github.com/Ulauncher/Ulauncher/releases/download/2.0.30/ulauncher_2.0.30.tar.gz")
+source=("ulauncher::git+https://github.com/Ulauncher/Ulauncher.git")
sha256sums=('SKIP')
+pkgver() {
+ cd ulauncher
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
prepare() {
cd ulauncher
+ sed -i "s/%VERSION%/${pkgver%.*.*}/g" setup.py
find -iname "*.py" | xargs sed -i 's=\(^#! */usr/bin.*\)python *$=\1python2='
}
build() {
cd ulauncher
python2 setup.py build
+ sh build-utils/build-preferences.sh
}
package() {