summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandr Gornostal2017-03-04 11:00:21 +0200
committerAleksandr Gornostal2017-03-04 11:00:21 +0200
commita61029b858f0fecd5ca71ca74c39573e28df6e5e (patch)
treedf02247053f2ad66c168fd68715f01051b411061
parentf98f40a5717fcc35abd25a0970407491bb4b3b6d (diff)
downloadaur-a61029b858f0fecd5ca71ca74c39573e28df6e5e.tar.gz
manual update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd732ec129f7..42206e2c3a94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-pkgbase = ulauncher-git
- pkgdesc = Convenient and fast way to launch your desktop applications.
- pkgver = 2.0.14.r0.gbdf867f
+# Generated by mksrcinfo v8
+# Sat Mar 4 08:56:16 UTC 2017
+pkgbase = ulauncher
+ pkgdesc = Application launcher for Linux
+ pkgver = 2.0.28
pkgrel = 1
url = http://ulauncher.io
arch = any
license = GPL3
- makedepends = git
- makedepends = npm
makedepends = python2-distutils-extra
- makedepends = python2-setuptools
depends = gobject-introspection-runtime
depends = libappindicator-gtk3
depends = libkeybinder3
@@ -21,8 +20,8 @@ pkgbase = ulauncher-git
depends = python2-xdg
provides = ulauncher
conflicts = ulauncher
- source = ulauncher::git+https://github.com/Ulauncher/Ulauncher.git
+ source = https://github.com/Ulauncher/Ulauncher/releases/download/2.0.28/ulauncher_2.0.28.tar.gz
sha256sums = SKIP
-pkgname = ulauncher-git
+pkgname = ulauncher
diff --git a/PKGBUILD b/PKGBUILD
index b8b34a3f9606..3d72d578defe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
-# Maintainer: Josip Ponjavic <josipponjavic at gmail dot com>
+# Maintainer: Aleksandr Gornostal <ulauncher.app@gmail.com>
-pkgname=ulauncher-git
-pkgver=2.0.14.r0.gbdf867f
+# To install, run `makepkg -is`
+
+pkgname=ulauncher
+pkgver=2.0.28
pkgrel=1
-pkgdesc='Convenient and fast way to launch your desktop applications.'
+pkgdesc='Application launcher for Linux'
arch=('any')
url="http://ulauncher.io"
license=('GPL3')
depends=('gobject-introspection-runtime' 'libappindicator-gtk3' 'libkeybinder3' 'webkit2gtk'
"python2-"{dbus,gobject,pyinotify,pysqlite,levenshtein,xdg})
-makedepends=('git' 'npm' "python2-"{distutils-extra,setuptools})
+makedepends=('python2-distutils-extra')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("ulauncher::git+https://github.com/Ulauncher/Ulauncher.git")
+source=("https://github.com/Ulauncher/Ulauncher/releases/download/2.0.28/ulauncher_2.0.28.tar.gz")
sha256sums=('SKIP')
-
-pkgver() {
- cd ulauncher
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
prepare() {
cd ulauncher
- sed -i "s/%VERSION%/${pkgver%.*.*}/g" setup.py
find -iname "*.py" | xargs sed -i 's=\(^#! */usr/bin.*\)python *$=\1python2='
}
build() {
cd ulauncher
python2 setup.py build
- sh build-utils/build-preferences.sh
}
package() {