summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbin Larsson2021-10-08 09:33:54 +0200
committerAlbin Larsson2021-10-08 09:33:54 +0200
commite431d678cb5c03a4c31de0e97646ce7b3aaa438b (patch)
treef3b812d377a9f36717e2b08401eb805eef438cb7
parent83c2b9393d6ccc5f51feae23b2d2a0c8cef32f0a (diff)
downloadaur-e431d678cb5c03a4c31de0e97646ce7b3aaa438b.tar.gz
Make install script ignore users PATH, so it won't use pyenv Python version
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b77de9993da2..015072817393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,7 +36,7 @@ prepare() {
build() {
cd ulauncher
- python setup.py build
+ env PATH=$(getconf PATH) python setup.py build
./ul build-preferences
}
@@ -48,7 +48,7 @@ check() {
package() {
cd ulauncher
export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ env PATH=$(getconf PATH) python setup.py install --root="$pkgdir" --optimize=1 --skip-build
rm -rf "$pkgdir"/usr/share/ulauncher/preferences/{no*,src,bow*,gul*,pack*}
find $pkgdir -type d -name __pycache__ | xargs rm -rf
}