summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurélien Ooms2017-05-11 23:24:07 +0200
committerAurélien Ooms2017-05-11 23:24:07 +0200
commitdfd780afd321da8b5d223ea713185cbb1f7c7969 (patch)
treed6779f4b75d571178d9e17d8455833ebfb2b4c01
downloadaur-dfd780afd321da8b5d223ea713185cbb1f7c7969.tar.gz
initial pkgbuild
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..714f3413b45d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ulb
+ pkgdesc = Scripts for use @ Université libre de Bruxelles
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/aureooms-ulb/ulb
+ arch = any
+ license = AGPL-3.0
+ makedepends = git
+ depends = bash
+ depends = coreutils
+ depends = wget
+ depends = perl
+ depends = grep
+ depends = fping
+ depends = iproute2
+ optdepends = pass
+ source = https://github.com/aureooms-ulb/ulb/archive/v1.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = ulb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07c9a808e892
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aurélien Ooms <aurelien.ooms@gmail.com>
+pkgname=ulb
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Scripts for use @ Université libre de Bruxelles"
+arch=(any)
+url="https://github.com/aureooms-ulb/${pkgname}"
+license=('AGPL-3.0')
+groups=()
+depends=('bash' 'coreutils' 'wget' 'perl' 'grep' 'fping' 'iproute2')
+makedepends=('git')
+checkdepends=()
+optdepends=('pass')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/aureooms-ulb/${pkgname}/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}