summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-09-03 15:23:10 +0200
committerbegin-theadventure2023-09-03 15:23:10 +0200
commit01e207bd2ddb010828584ca2a2cfc219ba761f61 (patch)
tree34f11c54fa1955a2bc7f95ad911d37fe36b38132
downloadaur-01e207bd2ddb010828584ca2a2cfc219ba761f61.tar.gz
0.1.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44b72b7104de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ultimate-tic-tac-toe
+ pkgdesc = Play Ultimate Tic Tac Toe
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/Nokse22/ultimate-tic-tac-toe
+ arch = aarch64
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = meson
+ depends = libadwaita
+ depends = python
+ source = git+https://github.com/Nokse22/ultimate-tic-tac-toe.git#tag=v0.1.2
+ sha256sums = SKIP
+
+pkgname = ultimate-tic-tac-toe
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1945537835a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=ultimate-tic-tac-toe
+pkgdesc='Play Ultimate Tic Tac Toe'
+pkgver=0.1.2
+pkgrel=1
+arch=('aarch64' 'x86_64')
+url="https://github.com/Nokse22/ultimate-tic-tac-toe"
+license=('GPL3')
+depends=('libadwaita' 'python')
+makedepends=('git' 'meson')
+checkdepends=('appstream-glib')
+source=("git+$url.git#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ chmod +x "$pkgdir/usr/bin/$pkgname"
+}