summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:35:07 +0200
committerM0Rf302015-06-17 16:35:07 +0200
commite5f2eeda5c9807c9fab5c6213224d7960bb7cdbf (patch)
tree5df94164f24378ad921d073008aae7e8ad4c874d
downloadaur-e5f2eeda5c9807c9fab5c6213224d7960bb7cdbf.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--ultimate_control.install9
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17669a67c9ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ultimate_control
+ pkgdesc = Ultimate Control is a set of software tools that allow you to take control of your computer wirelessly.
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://www.negusoft.com/index.php/ultimate-control
+ install = ultimate_control.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime-headless
+ source = http://www.negusoft.com/downloads/ultimate_control_v1.2_linux_64bit.tar.gz
+ md5sums = 0ad5bdbea3053ce419fd3b941262917b
+
+pkgname = ultimate_control
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..043d18efcb18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: M0Rf30
+
+pkgname=ultimate_control
+pkgver=1.2
+pkgrel=1
+pkgdesc="Ultimate Control is a set of software tools that allow you to take control of your computer wirelessly."
+arch=('i686' 'x86_64')
+url="http://www.negusoft.com/index.php/ultimate-control"
+license=('custom')
+depends=('java-runtime-headless')
+_arch='64bit'
+[[ "${CARCH}" = i686 ]] && _arch='32bit'
+source=("http://www.negusoft.com/downloads/${pkgname}_v${pkgver}_linux_${_arch}.tar.gz")
+md5sums=('0ad5bdbea3053ce419fd3b941262917b')
+[[ "$CARCH" == 'i686' ]] && md5sums[0]='23ba928ef36e63fe6d3a84e4b0bde485'
+install=ultimate_control.install
+
+package() {
+ cd ${srcdir}
+ mkdir -p ${pkgdir}/usr/lib/ucontrol
+ mkdir -p ${pkgdir}/usr/bin
+ cp -f -r lib/ucontrol.jar ${pkgdir}/usr/lib/ucontrol/ucontrol.jar
+ cp -f -r lib/icon.png ${pkgdir}/usr/lib/ucontrol/icon.png
+ cp -f -r bin/ucontrol ${pkgdir}/usr/bin/ucontrol
+ chmod 744 ${pkgdir}/usr/lib/ucontrol/*
+ install -vDm644 "Ultimate Control.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+}
diff --git a/ultimate_control.install b/ultimate_control.install
new file mode 100644
index 000000000000..16df57784306
--- /dev/null
+++ b/ultimate_control.install
@@ -0,0 +1,9 @@
+post_install () {
+ echo -e "You have to install Ultimate Mouse or Ultimate Gamepad on your phone. You just need to follow these steps:\n"
+ echo -e "1.Install the app. You can find it through your application provider (Google Play Market or App Store)."
+ echo -e "\tYou can find the links in the downloads section too."
+ echo -e "2.Open the application and select the connection type you would like to use:"
+ echo -e "\tBluetooth or WiFi (*Bluetooth is not available for iPhone and iOS)"
+ echo -e "3.Select the receiver from the list to establish the connection"
+ echo -e "4.Enjoy the Ultimate Control experience!"
+}