summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2018-05-19 12:59:06 +0200
committerfenuks2018-05-19 12:59:06 +0200
commitc2a786b64facceed166fa552bd850f1c76f37ddf (patch)
tree80b8e566f88fc9619bfa3de8df1390d9de333e20
parent469387b4b3826ff71a1f2e78bca0fce12a031081 (diff)
downloadaur-c2a786b64facceed166fa552bd850f1c76f37ddf.tar.gz
Update ffmpeg to 3.4
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b93f7494a39..e00c5d6bc83b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Apr 17 20:06:14 UTC 2017
+# Sat May 19 10:58:43 UTC 2018
pkgbase = ultrastardxwp-git
pkgdesc = UltraStar Deluxe WorldParty is a free and open source karaoke game. It allows up to six players to sing along with music using microphones in order to score points, depending on the pitch of the voice and the rhythm of singing.
- pkgver = r25.9f5f917
+ pkgver = r111.c1da37e
pkgrel = 1
url = http://ultrastar-es.org
install = ultrastardxwp-git.install
@@ -11,7 +11,7 @@ pkgbase = ultrastardxwp-git
license = GPL
makedepends = git
makedepends = fpc
- depends = ffmpeg2.8
+ depends = ffmpeg3.4
depends = lua
depends = pcre
depends = portaudio
diff --git a/PKGBUILD b/PKGBUILD
index b3fed0be3184..c8e1addc365b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,15 @@
_usdx_package=WorldParty
_pkgname=ultrastardxwp
+_ffmpeg="ffmpeg3.4"
pkgname=${_pkgname}-git
-pkgver=r25.9f5f917
+pkgver=r111.c1da37e
pkgrel=1
pkgdesc="UltraStar Deluxe WorldParty is a free and open source karaoke game. It allows up to six players to sing along with music using microphones in order to score points, depending on the pitch of the voice and the rhythm of singing."
arch=("i686" "x86_64")
url="http://ultrastar-es.org"
license=("GPL")
-depends=("ffmpeg2.8" "lua" "pcre" "portaudio" "sdl2" "sdl2_gfx" "sdl2_mixer" "sdl2_ttf" "sdl2_image" "sdl2_net" "sqlite" "ttf-dejavu" "ttf-freefont")
+depends=(${_ffmpeg} "lua" "pcre" "portaudio" "sdl2" "sdl2_gfx" "sdl2_mixer" "sdl2_ttf" "sdl2_image" "sdl2_net" "sqlite" "ttf-dejavu" "ttf-freefont")
makedepends=("git" "fpc")
optdepends=()
conflicts=("${pkgname}")
@@ -35,13 +36,13 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
chmod +x configure
- PKG_CONFIG_PATH="/usr/lib/ffmpeg2.8/pkgconfig" ./configure --prefix=/usr
+ PKG_CONFIG_PATH="/usr/lib/${_ffmpeg}/pkgconfig" ./configure --prefix=/usr
make
}
package() {
cd "${srcdir}/${_pkgname}"
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="${pkgdir}"
install -Dm644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${pkgdir}/usr/share/${_usdx_package}/resources/icons/${_usdx_package}.png" "${pkgdir}/usr/share/icons/${_usdx_package}.png"
}