summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJCoMcL2019-12-24 21:55:20 +0000
committerJCoMcL2019-12-24 21:55:20 +0000
commit8059a8ca84a99010a8028876ed0540289a670088 (patch)
tree050fe87db002d563825897efc96aea34a29345c5
downloadaur-8059a8ca84a99010a8028876ed0540289a670088.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c86ce88579c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = umenu
+ pkgdesc = command-line menu (a la dmenu, slmenu) with single-keypress interaction
+ pkgver = 0.4.0.gc534c22
+ pkgrel = 1
+ url = https://github.com/JCoMcL/umenu.git
+ arch = x86_64
+ license = Unlicense
+ makedepends = git
+ depends = sh
+ source = git+https://github.com/JCoMcL/umenu
+ md5sums = SKIP
+
+pkgname = umenu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7124fdcefdb5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: jcomcl rapcyss@gmail.com
+
+pkgname=umenu
+pkgver=0.4.0.gc534c22
+pkgrel=1
+pkgdesc="command-line menu (a la dmenu, slmenu) with single-keypress interaction"
+arch=('x86_64')
+url="https://github.com/JCoMcL/umenu.git"
+license=('Unlicense')
+depends=('sh')
+makedepends=('git')
+source=("git+https://github.com/JCoMcL/umenu")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed 's/^v//;s/-/./g;q'
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+}