summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Soares2016-04-10 15:51:18 -0400
committerRafael Soares2016-04-10 15:51:18 -0400
commit13edc8f994e07c1afe67dd4f0e59caaf84a72fb3 (patch)
tree146e86d76b8796e6407712747dfc746f7e63a763
downloadaur-13edc8f994e07c1afe67dd4f0e59caaf84a72fb3.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitlab-ci.yml12
-rw-r--r--CONTRIBUTING.md14
-rw-r--r--PKGBUILD90
-rw-r--r--README.md8
-rw-r--r--changelog10
-rw-r--r--umldesigner.desktop8
7 files changed, 162 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c608ec01387f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Apr 10 19:50:00 UTC 2016
+pkgbase = umldesigner
+ pkgdesc = Graphical tooling to edit and visualize UML models
+ pkgver = 6.0.0
+ pkgrel = 1
+ url = http://www.umldesigner.org/
+ changelog = changelog
+ arch = i686
+ arch = x86_64
+ license = EPL
+ makedepends = maven
+ makedepends = ruby
+ source = https://github.com/ObeoNetwork/UML-Designer/archive/6.0.0.tar.gz
+ source = umldesigner.desktop
+ sha256sums = d79d0113e0913ecb638b59964c0c2031e6fc1de3c29c37c433c0fd4b4798ba80
+ sha256sums = SKIP
+
+pkgname = umldesigner
+
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 000000000000..5af12e77b9a6
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,12 @@
+stages:
+ - build
+ - test
+ - deploy
+
+job_makepkg:
+ stage: build
+ script:
+ - makepkg -srf --noconfirm --noprogressbar
+ tags:
+ - shell
+ - arch
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
new file mode 100644
index 000000000000..7d6efdd04338
--- /dev/null
+++ b/CONTRIBUTING.md
@@ -0,0 +1,14 @@
+How to contribute:
+
+
+0 - Sign in to https://gitlab.com
+
+1 - Go to https://gitlab.com/aur-ci/umldesigner
+
+2 - Submit a new Issue and/or:
+
+3 - Fork this project
+
+4 - Create a new branch
+
+5 - Submit a new merge request
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a68aa7ef4a2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# umldesigner
+# Contributing: https://gitlab.com/aur-ci/umldesigner.git
+# Builds: https://gitlab.com/aur-ci/umldesigner/builds
+#pkgbase=
+pkgname=umldesigner
+
+# Version
+pkgver=6.0.0
+pkgrel=1
+#epoch=
+
+# Generic
+pkgdesc="Graphical tooling to edit and visualize UML models"
+arch=('i686' 'x86_64')
+url="http://www.umldesigner.org/"
+license=('EPL')
+#groups=()
+
+# Dependencies
+#depends=('')
+#optdepends=()
+makedepends=('maven' 'ruby')
+#checkdepends=()
+
+# Package Relations
+#provides=()
+#conflicts=()
+#replaces=()
+
+# Others
+#backup=()
+#options=()
+#install=actor
+changelog=changelog
+
+# Sources
+source=("https://github.com/ObeoNetwork/UML-Designer/archive/${pkgver}.tar.gz" "umldesigner.desktop")
+#source_i686=()
+#source_x86_64=()
+#noextract=()
+#validpgpkeys=()
+
+# Integrity
+#md5sums=('')
+#sha1sums=()
+sha256sums=('d79d0113e0913ecb638b59964c0c2031e6fc1de3c29c37c433c0fd4b4798ba80' 'SKIP')
+
+#pkgver() {
+#}
+
+prepare() {
+ gem install jekyll --version '= 1.5.1'
+ gem install RedCloth
+ export PATH="$PATH":/home/boss/.gem/ruby/2.3.0/bin
+}
+
+build() {
+ # Build documentation web site
+ cd UML-Designer-${pkgver}/documentation
+ ls
+ jekyll build
+ ls
+ cd ../
+ # Integrate the documentation to Eclipse
+ rm -rf plugins/org.obeonetwork.dsl.uml2.design.doc/html
+ cp -r documentation/_site plugins/org.obeonetwork.dsl.uml2.design.doc/html
+ ls plugins/org.obeonetwork.dsl.uml2.design.doc/html
+ # Build uml designer
+ mvn clean verify
+ # Build uml designer products
+ mvn clean package -f releng/org.obeonetwork.dsl.uml2.product.parent/pom.xml
+}
+
+#check() {
+#}
+
+package() {
+ install -dm755 "$pkgdir/usr/share/applications/"
+ install -dm755 "$pkgdir/usr/bin/"
+ install -Dm755 "$srcdir/umldesigner.desktop" "$pkgdir/usr/share/applications/"
+ if [[ "$CARCH" == "i686" ]]; then
+ cp -r "${srcdir}/UML-Designer-${pkgver}/packaging/org.obeonetwork.dsl.uml2.product\
+/target/products/org.obeonetwork.dsl.uml2.branding.product/linux/gtk/x86" "${pkgdir}/opt/"
+ elif [[ "$CARCH" == "x86_64" ]]; then
+ cp -r "${srcdir}/UML-Designer-${pkgver}/packaging/org.obeonetwork.dsl.uml2.product\
+/target/products/org.obeonetwork.dsl.uml2.branding.product/linux/gtk/x86_64" "${pkgdir}/opt/"
+ fi
+ ln -s "/opt/UMLDesigner/UMLDesigner" "${pkgdir}/usr/bin/UMLDesigner"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..3f223c807cd6
--- /dev/null
+++ b/README.md
@@ -0,0 +1,8 @@
+AUR Package:
+
+
+UMLDesigner
+
+Contributing: https://gitlab.com/aur-ci/umldesigner.git
+
+Builds: https://gitlab.com/aur-ci/umldesigner/builds
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..c56d5f39fa90
--- /dev/null
+++ b/changelog
@@ -0,0 +1,10 @@
+Based on Sirius 3.0
+Based on Mars.1
+Uses AQL
+Builds with Travis and uploaded on S3: https://travis-ci.org/ObeoNetwork/UML-Designer
+Tested thanks to Travis and RCPTT tests: https://travis-ci.org/ObeoNetwork/UML-Designer-UI-Tests https://github.com/ObeoNetwork/UML-Designer-UI-Tests
+Bug fixes on Class diagram (#774, #764, #759, #727)
+Bug fixes on Deployment diagram (#728)
+Bug fixes on Component diagram (#664)
+New Mac App bundle based on Mars.1. Pay attention do not perform an "update" from an existing "directory layout" installation. You must download a fresh version.
+Provides an Oomph setup: https://github.com/ObeoNetwork/UML-Designer/blob/master/releng/org.obeonetwork.dsl.uml2.settings/UMLDesigner.setup
diff --git a/umldesigner.desktop b/umldesigner.desktop
new file mode 100644
index 000000000000..83dc3a48bd1b
--- /dev/null
+++ b/umldesigner.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=UMLDesigner
+Version=6.0.0
+Comment=Graphical tooling to edit and visualize UML models
+Exec=/opt/UMLDesigner/UMLDesigner %u
+Icon=/opt/UMLDesigner/icon.xpm
+Type=Application
+Categories=Development;UML;