summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Soares2016-03-23 22:20:17 -0400
committerRafael Soares2016-03-23 22:20:17 -0400
commit04b58c5749591f23022e7aa1b12856dd22676861 (patch)
tree5eba8f6a597ccf166749bbb259f2df997298ae21
parent4b0e97b1456ce5cf9cb12d19b5d81ed4e89676c8 (diff)
downloadaur-04b58c5749591f23022e7aa1b12856dd22676861.tar.gz
Add umlet.sh
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--umlet.sh14
3 files changed, 21 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90c2b86091b0..df92715f25e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Mar 24 00:55:43 UTC 2016
+# Thu Mar 24 02:18:42 UTC 2016
pkgbase = umlet
pkgdesc = Free UML Tool for Fast UML Diagrams
pkgver = 14.1.1
@@ -12,9 +12,11 @@ pkgbase = umlet
makedepends = unzip
depends = java-environment
replaces = eclipse-umlet
+ source = umlet.sh
source = umlet.desktop
source = https://github.com/umlet/umlet/archive/2016-01-14_UMLet_v14.1.1.tar.gz
md5sums = SKIP
+ md5sums = SKIP
md5sums = 86d2987ad76522e926584a9b4532fc50
pkgname = umlet-standalone
diff --git a/PKGBUILD b/PKGBUILD
index a9492424d934..d8487bcea89d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,14 +35,14 @@ replaces=('eclipse-umlet')
changelog=changelog
# Sources
-source=("umlet.desktop" "https://github.com/umlet/umlet/archive/${_tag}.tar.gz")
+source=("umlet.sh" "umlet.desktop" "https://github.com/umlet/umlet/archive/${_tag}.tar.gz")
#source_i686=("")
#source_x86_64=("")
#noextract=()
#validpgpkeys=()
# Integrity
-md5sums=('SKIP' '86d2987ad76522e926584a9b4532fc50')
+md5sums=('SKIP' 'SKIP' '86d2987ad76522e926584a9b4532fc50')
#md5sums_i686=('')
#md5sums_x86_64=('')
#sha1sums=()
@@ -69,7 +69,9 @@ package_umlet-standalone() {
install -dm755 "$pkgdir/opt/"
unzip "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-standalone/target/umlet-standalone-${pkgver}.zip" -d "$pkgdir/opt"
rm "$pkgdir/opt/Umlet/umlet.desktop"
+ rm "$pkgdir/opt/Umlet/umlet.sh"
install -Dm644 "$srcdir/umlet.desktop" "$pkgdir/usr/share/applications/"
+ install -Dm755 "$srcdir/umlet.sh" "$pkgdir/usr/bin/"
}
package_umlet-eclipse-plugin() {
diff --git a/umlet.sh b/umlet.sh
new file mode 100644
index 000000000000..142710c1b31b
--- /dev/null
+++ b/umlet.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Shell script for running umlet from the command prompt in linux
+
+# If you want to put umlet.sh in your home bin directory ($HOME/bin/) to start it from anywhere with
+# $ umlet.sh myDiagram.uxf
+# you must specify the programDir directly instead
+programDir=/opt/Umlet
+#programDir=$(cd $(dirname $0);pwd)
+
+if [ $# -eq 1 ]
+ then java -Dsun.java2d.xrender=f -jar ${programDir}/umlet.jar -filename="$1"
+ else java -Dsun.java2d.xrender=f -jar ${programDir}/umlet.jar "$@"
+fi