summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 20:22:37 +0100
committerBartłomiej Piotrowski2018-01-06 20:22:37 +0100
commit203a728fa3378ee967462a4cbe513b0217ba25dd (patch)
tree3ba75347eda76b957679b69c0ea6a2c872b2e800
parent030f1ccbbcc6dd363c089bdf38833c0d0da2cbe5 (diff)
downloadaur-203a728fa3378ee967462a4cbe513b0217ba25dd.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD108
-rw-r--r--UMLet.sh.diff16
-rw-r--r--umlet.desktop4
4 files changed, 59 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45fef156515d..406f64ced970 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Apr 14 01:07:46 UTC 2016
pkgbase = umlet
- pkgdesc = Free UML Tool for Fast UML Diagrams
+ pkgdesc = Free UML Tool for Fast UML Diagrams (stand-alone version)
pkgver = 14.2
pkgrel = 1
- url = http://www.umlet.com/
+ url = http://www.umlet.com
arch = any
- license = GPL3
- makedepends = maven
+ license = GPL
makedepends = unzip
- depends = java-environment
- source = umlet.sh
+ makedepends = patch
+ depends = java-runtime
+ source = http://www.umlet.com/umlet_14_2/umlet-standalone-14.2.zip
source = umlet.desktop
- source = https://github.com/umlet/umlet/archive/2016-04-03_UMLet_v14.2.tar.gz
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 46221fd47003f88ffe881954d68dfc83
+ source = UMLet.sh.diff
+ md5sums = 25d249dc14dc93cfe8aebee5b138fcde
+ md5sums = 4efcfeea2f54b849bc86e3f1905449be
+ md5sums = ef9620bd90f0e3bba7133629cf5885c8
-pkgname = umlet-standalone
- pkgdesc = Free UML Tool for Fast UML Diagrams (Standalone Version)
-
-pkgname = umlet-eclipse-plugin
- pkgdesc = Free UML Tool for Fast UML Diagrams (Eclipse Plugin Version)
- depends = eclipse
- replaces = eclipse-umlet
+pkgname = umlet
diff --git a/PKGBUILD b/PKGBUILD
index c30d998263cd..187fa07b80dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,85 +1,37 @@
-# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
-# umlet
-# Contributing: https://github.com/rafaelsoaresbr/umlet.git
-# Builds: https://gitlab.com/rafaelsoaresbr/umlet/builds
-pkgbase="umlet"
-pkgname=($pkgbase{-standalone,-eclipse-plugin})
+# $Id: PKGBUILD 194152 2016-10-31 13:48:24Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Gleidson Echeli <gleidson dot echeli at gmail dot com>
-# Version
+pkgname=umlet
pkgver=14.2
+_pkgver=14_2
pkgrel=1
-#epoch=
-_date="2016-04-03"
-_tag="${_date}_UMLet_v${pkgver}"
-
-# Generic
-pkgdesc="Free UML Tool for Fast UML Diagrams"
+pkgdesc="Free UML Tool for Fast UML Diagrams (stand-alone version)"
arch=('any')
-url="http://www.umlet.com/"
-license=('GPL3')
-#groups=()
-
-# Dependencies
-depends=('java-environment')
-#optdepends=()
-makedepends=('maven' 'unzip')
-#checkdepends=()
-
-# Package Relations
-#provides=()
-#conflicts=()
-#replaces=()
-
-# Others
-#backup=()
-#options=()
-#install=actor
-#changelog=changelog
-
-# Sources
-source=("umlet.sh" "umlet.desktop" "https://github.com/umlet/umlet/archive/${_tag}.tar.gz")
-#source_i686=("")
-#source_x86_64=("")
-#noextract=()
-#validpgpkeys=()
-
-# Integrity
-md5sums=('SKIP' 'SKIP' '46221fd47003f88ffe881954d68dfc83')
-#md5sums_i686=('')
-#md5sums_x86_64=('')
-#sha1sums=()
-#sha256sums=()
-
-#pkgver() {
-#}
-
-#prepare() {
-#}
-
-build() {
- cd umlet-${_date}_UMLet_v${pkgver}
- mvn clean install
-}
-
-#check() {
-#}
-
-package_umlet-standalone() {
- pkgdesc="${pkgdesc} (Standalone Version)"
- install -dm755 "$pkgdir/usr/share/applications/"
- install -dm755 "$pkgdir/usr/bin/"
- install -dm755 "$pkgdir/opt/"
- unzip "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-standalone/target/umlet-standalone-${pkgver}.zip" -d "$pkgdir/opt"
- rm "$pkgdir/opt/Umlet/umlet.desktop"
- rm "$pkgdir/opt/Umlet/umlet.sh"
- install -Dm644 "$srcdir/umlet.desktop" "$pkgdir/usr/share/applications/"
- install -Dm755 "$srcdir/umlet.sh" "$pkgdir/usr/bin/"
+url="http://www.umlet.com"
+license=('GPL')
+depends=('java-runtime')
+makedepends=('unzip' 'patch')
+source=("http://www.umlet.com/umlet_${_pkgver}/umlet-standalone-${pkgver}.zip"
+ 'umlet.desktop'
+ 'UMLet.sh.diff')
+md5sums=('25d249dc14dc93cfe8aebee5b138fcde'
+ '4efcfeea2f54b849bc86e3f1905449be'
+ 'ef9620bd90f0e3bba7133629cf5885c8')
+
+prepare() {
+ cd "$srcdir"/Umlet
+ patch -Np1 -i ../UMLet.sh.diff
+ rm -f umlet.sh.orig
+ rm -f Umlet.exe
}
-package_umlet-eclipse-plugin() {
- pkgdesc="${pkgdesc} (Eclipse Plugin Version)"
- depends=('eclipse')
- replaces=('eclipse-umlet')
- install -dm755 "$pkgdir/usr/share/eclipse/plugins"
- install -Dm644 "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-eclipse-plugin/target/com.umlet.plugin-${pkgver}.jar" "$pkgdir/usr/share/eclipse/plugins"
+package() {
+ cd "$srcdir"/Umlet
+ mkdir -p "$pkgdir"/usr/bin
+ ln -s /usr/share/umlet/umlet.sh "$pkgdir"/usr/bin/umlet
+ install -d -m755 "$pkgdir"/usr/share
+ mv "$srcdir"/Umlet "$pkgdir"/usr/share/umlet
+ install -D -m644 "$srcdir"/umlet.desktop "$pkgdir"/usr/share/applications/umlet.desktop
+ chmod a+x "$pkgdir"/usr/share/umlet/umlet.sh
}
diff --git a/UMLet.sh.diff b/UMLet.sh.diff
new file mode 100644
index 000000000000..7cd2d3c31ea9
--- /dev/null
+++ b/UMLet.sh.diff
@@ -0,0 +1,16 @@
+diff -wbBur Umlet/umlet.sh Umlet.my/umlet.sh
+--- Umlet/umlet.sh 2011-02-18 18:27:14.000000000 +0000
++++ Umlet.my/umlet.sh 2011-03-03 15:20:48.000000000 +0000
+@@ -2,11 +2,7 @@
+
+ # Shell script for running umlet from the command prompt in linux
+
+-# If you want to put umlet.sh in your home bin directory ($HOME/bin/) to start it from anywhere with
+-# $ umlet.sh myDiagram.uxf
+-# you must specify the programDir directly instead
+-#programDir=/path/to/umlet
+-programDir=$(cd $(dirname $0);pwd)
++programDir=/usr/share/umlet
+
+ if [ $# -gt 0 ]
+ then java -jar ${programDir}/umlet.jar -filename="$1"
diff --git a/umlet.desktop b/umlet.desktop
index 2b3075e121a4..f88f02a255b1 100644
--- a/umlet.desktop
+++ b/umlet.desktop
@@ -4,8 +4,8 @@ Type=Application
Name=UMLet
GenericName=UMLet
Comment=Free UML Tool for Fast UML Diagrams
-Exec=java -jar /opt/Umlet/umlet.jar %u
-Icon=/opt/Umlet/img/umlet_logo.png
+Exec=umlet
+Icon=/usr/share/umlet/img/umlet_logo.png
Terminal=false
Categories=Development;
StartupNotify=true