summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Soares2016-03-23 20:39:10 -0400
committerRafael Soares2016-03-23 20:39:10 -0400
commitd0599a70caf67dcebbe52b64b1c1cdd6172c5bae (patch)
tree54b070893b479e04443e468e3fd22e17b0a5a05a
downloadaur-d0599a70caf67dcebbe52b64b1c1cdd6172c5bae.tar.gz
First Commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD80
-rw-r--r--changelog5
-rw-r--r--umlet.desktop11
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60e794330af8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Thu Mar 24 00:12:52 UTC 2016
+pkgbase = umlet
+ pkgdesc = Free UML Tool for Fast UML Diagrams
+ pkgver = 14.1.1
+ pkgrel = 1
+ url = http://www.umlet.com/
+ changelog = changelog
+ arch = any
+ license = GPLv3
+ makedepends = maven
+ makedepends = unzip
+ depends = java-environment
+ replaces = eclipse-umlet
+ source = umlet.desktop
+ source = https://github.com/umlet/umlet/archive/2016-01-14_UMLet_v14.1.1.tar.gz
+ md5sums = SKIP
+ md5sums = 86d2987ad76522e926584a9b4532fc50
+
+pkgname = umlet-standalone
+ pkgdesc = Free UML Tool for Fast UML Diagrams (Standalone Version)
+
+pkgname = umlet-eclipse-plugin
+ pkgdesc = Free UML Tool for Fast UML Diagrams (Eclipse Plugin Version)
+ optdepends = eclipse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2adae5cf0fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer=rafaelsoaresbr <rafaelsoaresbr@gmail.com>
+# Package name
+pkgbase="umlet"
+pkgname=($pkgbase{-standalone,-eclipse-plugin})
+
+# Version
+pkgver=14.1.1
+pkgrel=1
+#epoch=
+_date="2016-01-14"
+_tag="${_date}_UMLet_v${pkgver}"
+
+# Generic
+pkgdesc="Free UML Tool for Fast UML Diagrams"
+arch=('any')
+url="http://www.umlet.com/"
+license=('GPLv3')
+#groups=()
+
+# Dependencies
+depends=('java-environment')
+#optdepends=()
+makedepends=('maven' 'unzip')
+#checkdepends=()
+
+# Package Relations
+#provides=()
+#conflicts=()
+replaces=('eclipse-umlet')
+
+# Others
+#backup=()
+#options=()
+#install=actor
+changelog=changelog
+
+# Sources
+source=("umlet.desktop" "https://github.com/umlet/umlet/archive/${_tag}.tar.gz")
+#source_i686=("")
+#source_x86_64=("")
+#noextract=()
+#validpgpkeys=()
+
+# Integrity
+md5sums=('SKIP' '86d2987ad76522e926584a9b4532fc50')
+#md5sums_i686=('')
+#md5sums_x86_64=('')
+#sha1sums=()
+#sha256sums=()
+
+#pkgver() {
+#}
+
+#prepare() {
+#}
+
+build() {
+ cd umlet-${_date}_UMLet_v${pkgver}
+ mvn clean install
+}
+
+#check() {
+#}
+
+package_umlet-standalone() {
+ pkgdesc="Free UML Tool for Fast UML Diagrams (Standalone Version)"
+ install -dm755 "$pkgdir/usr/share/applications/"
+ install -dm755 "$pkgdir/usr/bin/"
+ install -dm755 "$pkgdir/opt/"
+ unzip "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-standalone/target/umlet-standalone-${pkgver}.zip" -d "$pkgdir/opt"
+ rm "$pkgdir/opt/Umlet/umlet.desktop"
+ install -Dm644 "$srcdir/umlet.desktop" "$pkgdir/usr/share/applications/"
+}
+
+package_umlet-eclipse-plugin() {
+ pkgdesc="Free UML Tool for Fast UML Diagrams (Eclipse Plugin Version)"
+ optdepends=('eclipse')
+ install -dm755 "$pkgdir/usr/share/eclipse/plugins"
+ install -Dm644 "$srcdir/umlet-${_date}_UMLet_v${pkgver}/umlet-eclipse-plugin/target/com.umlet.plugin-${pkgver}.jar" "$pkgdir/usr/share/eclipse/plugins"
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..fe9488789ba9
--- /dev/null
+++ b/changelog
@@ -0,0 +1,5 @@
+New in UMLet 14.1.1 stand-alone and UMLet 14.1 Eclipse plugin
+- New custom elements
+- New sequence all-in-one
+- OS-specific config dir handling
+- Many additional fixes; see current github issue tracker
diff --git a/umlet.desktop b/umlet.desktop
new file mode 100644
index 000000000000..2b3075e121a4
--- /dev/null
+++ b/umlet.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=UMLet
+GenericName=UMLet
+Comment=Free UML Tool for Fast UML Diagrams
+Exec=java -jar /opt/Umlet/umlet.jar %u
+Icon=/opt/Umlet/img/umlet_logo.png
+Terminal=false
+Categories=Development;
+StartupNotify=true