summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian "Beej Jorgensen" Hall2019-02-03 14:42:44 -0800
committerBrian "Beej Jorgensen" Hall2019-02-03 14:42:44 -0800
commit395dba03f4277747e2c3059dcc4fd59e3b836136 (patch)
tree8e6e03961ef82ebd75ed2498d83e236629cb35a8
parent27f74290f62d899c63736f6c33c79b12e3f0a171 (diff)
downloadaur-395dba03f4277747e2c3059dcc4fd59e3b836136.tar.gz
fix compiler warnings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--umoria-5.6-aur.patch160
3 files changed, 152 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45fcd67a4a51..23ec342b9e64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = umoria
pkgdesc = Rogue-like dungeon crawler
pkgver = 5.6
- pkgrel = 4
+ pkgrel = 5
url = http://free-moria.sourceforge.net/
install = umoria.install
arch = i686
@@ -13,7 +13,7 @@ pkgbase = umoria
backup = usr/share/umoria/files/scores
source = umoria-5.6-aur.patch
source = umoria-5.6.tar.gz::https://github.com/HunterZ/umoria/archive/5.6.tar.gz
- sha512sums = 65c264ce47c24d428aa956865ec46b90eb343703cb80ed62b5eababe7329f4ee81f61a035a0cca0573b8537eab9bc41804bd66473d489821477e4c11cfba2bee
+ sha512sums = 0a24d506ca6316f498f69fe8996fa7bf73110d99350137bb50b56f53c3eef3bc0379c2d04bc986cc28b50377684f90c0f402923e5283bae6c244d42d521192bd
sha512sums = d73fa55bc8609d1bb6727b59affb8f1461e6439d2f97de0b45e8f56e01d95a2b500ed4d86ac2690d831ff7e9492e604bcd3dcc47c253b44ab70d3f5da5457067
pkgname = umoria
diff --git a/PKGBUILD b/PKGBUILD
index 1f9f7bf1f3a1..156e0475bc86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Beej Jorgensen <beej@beej.us>
pkgname=umoria
pkgver=5.6
-pkgrel=4
+pkgrel=5
pkgdesc="Rogue-like dungeon crawler"
arch=('i686' 'x86_64')
url="http://free-moria.sourceforge.net/"
@@ -14,11 +14,10 @@ source=(
${pkgname}-${pkgver}.tar.gz::https://github.com/HunterZ/${pkgname}/archive/${pkgver}.tar.gz
)
install=${pkgname}.install
-sha512sums=('65c264ce47c24d428aa956865ec46b90eb343703cb80ed62b5eababe7329f4ee81f61a035a0cca0573b8537eab9bc41804bd66473d489821477e4c11cfba2bee'
+sha512sums=('0a24d506ca6316f498f69fe8996fa7bf73110d99350137bb50b56f53c3eef3bc0379c2d04bc986cc28b50377684f90c0f402923e5283bae6c244d42d521192bd'
'd73fa55bc8609d1bb6727b59affb8f1461e6439d2f97de0b45e8f56e01d95a2b500ed4d86ac2690d831ff7e9492e604bcd3dcc47c253b44ab70d3f5da5457067')
prepare() {
- echo ">>>>>>> " $srcdir
cd "$srcdir/${pkgname}-$pkgver"
patch -Np1 < ../${pkgname}-${pkgver}-aur.patch
diff --git a/umoria-5.6-aur.patch b/umoria-5.6-aur.patch
index 4fac5c93bfd6..cf2a1e4c6d6f 100644
--- a/umoria-5.6-aur.patch
+++ b/umoria-5.6-aur.patch
@@ -1,6 +1,6 @@
-diff -Naur moria-5.6/source/config.h moria-5.6-aur/source/config.h
---- moria-5.6/source/config.h 2008-10-13 16:44:36.000000000 -0700
-+++ moria-5.6-aur/source/config.h 2014-10-14 00:22:12.121012390 -0700
+diff -Naur umoria-5.6/source/config.h umoria-5.6-aur/source/config.h
+--- umoria-5.6/source/config.h 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/config.h 2019-02-03 14:15:12.669986292 -0800
@@ -240,6 +240,7 @@
/* Generic UNIX */
@@ -28,10 +28,60 @@ diff -Naur moria-5.6/source/config.h moria-5.6-aur/source/config.h
#endif
#endif
-diff -Naur moria-5.6/source/files.c moria-5.6-aur/source/files.c
---- moria-5.6/source/files.c 2008-10-13 16:44:36.000000000 -0700
-+++ moria-5.6-aur/source/files.c 2014-10-14 00:22:16.457384250 -0700
-@@ -126,19 +126,19 @@
+diff -Naur umoria-5.6/source/death.c umoria-5.6-aur/source/death.c
+--- umoria-5.6/source/death.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/death.c 2019-02-03 14:28:26.730764222 -0800
+@@ -20,6 +20,7 @@
+
+ /* Must read this before externs.h, as some global declarations use FILE. */
+ #include <stdio.h>
++#include <unistd.h>
+
+ #include "config.h"
+ #include "constant.h"
+@@ -63,7 +64,7 @@
+ #else
+ #ifdef unix
+ #ifdef USG
+-unsigned short getuid(), getgid();
++//unsigned short getuid(), getgid();
+ #else
+ #ifndef SECURE
+ #ifdef BSD4_3
+diff -Naur umoria-5.6/source/externs.h umoria-5.6-aur/source/externs.h
+--- umoria-5.6/source/externs.h 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/externs.h 2019-02-03 14:27:25.080958861 -0800
+@@ -342,7 +342,7 @@
+
+ /* io.c */
+ #ifdef SIGTSTP
+-int suspend(void);
++void suspend(int);
+ #endif
+ void init_curses(void);
+ void moriaterm(void);
+@@ -848,7 +848,7 @@
+
+ /* io.c */
+ #ifdef SIGTSTP
+-int suspend();
++void suspend(int);
+ #endif
+ void init_curses();
+ void moriaterm();
+diff -Naur umoria-5.6/source/files.c umoria-5.6-aur/source/files.c
+--- umoria-5.6/source/files.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/files.c 2019-02-03 14:21:45.638705566 -0800
+@@ -7,6 +7,8 @@
+ included in all such copies. */
+
+ #include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
+
+ #if 0
+ /* moved to externs.h to avoid VMS 'psect' problem */
+@@ -126,19 +128,19 @@
if (strlen(in_line) > 3)
{
if (!strncmp(in_line, "SUN:", 4))
@@ -58,10 +108,38 @@ diff -Naur moria-5.6/source/files.c moria-5.6-aur/source/files.c
}
(void) fclose(file1);
}
-diff -Naur moria-5.6/source/io.c moria-5.6-aur/source/io.c
---- moria-5.6/source/io.c 2008-10-13 16:44:36.000000000 -0700
-+++ moria-5.6-aur/source/io.c 2014-10-14 00:22:21.280389695 -0700
-@@ -1569,6 +1569,8 @@
+diff -Naur umoria-5.6/source/io.c umoria-5.6-aur/source/io.c
+--- umoria-5.6/source/io.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/io.c 2019-02-03 14:26:29.717800645 -0800
+@@ -19,6 +19,10 @@
+ along with Umoria. If not, see <http://www.gnu.org/licenses/>. */
+
+ #include <stdio.h>
++#include <sys/wait.h>
++
++typedef void (*sighandler_t)(int);
++sighandler_t sysv_signal(int signum, sighandler_t handler);
+
+ #include "config.h"
+
+@@ -249,7 +253,7 @@
+ Handle the stop and start signals. This ensures that the log
+ is up to date, and that the terminal is fully reset and
+ restored. */
+-int suspend()
++void suspend(int s)
+ {
+ #ifdef USG
+ /* for USG systems with BSDisms that have SIGTSTP defined, but don't
+@@ -280,7 +284,6 @@
+ (void) wrefresh(curscr);
+ py.misc.male &= ~2;
+ #endif
+- return 0;
+ }
+ #endif
+ #endif
+@@ -1569,6 +1572,8 @@
void bell()
{
@@ -70,7 +148,7 @@ diff -Naur moria-5.6/source/io.c moria-5.6-aur/source/io.c
put_qio();
/* The player can turn off beeps if he/she finds them annoying. */
-@@ -1578,7 +1580,7 @@
+@@ -1578,7 +1583,7 @@
#ifdef MAC
mac_beep();
#else
@@ -79,3 +157,61 @@ diff -Naur moria-5.6/source/io.c moria-5.6-aur/source/io.c
#endif
}
+diff -Naur umoria-5.6/source/main.c umoria-5.6-aur/source/main.c
+--- umoria-5.6/source/main.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/main.c 2019-02-03 14:20:13.572335190 -0800
+@@ -67,6 +67,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #include "config.h"
+ #include "constant.h"
+@@ -111,7 +112,7 @@
+ #ifndef AMIGA
+ #ifdef USG
+ #if !defined(MSDOS) && !defined(ATARIST_TC)
+-unsigned short getuid(), getgid();
++//unsigned short getuid(), getgid();
+ #endif
+ #else
+ #ifndef SECURE
+diff -Naur umoria-5.6/source/save.c umoria-5.6-aur/source/save.c
+--- umoria-5.6/source/save.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/save.c 2019-02-03 14:32:12.460054172 -0800
+@@ -26,6 +26,9 @@
+ #endif
+
+ #include <stdio.h>
++#include <unistd.h>
++#include <fcntl.h>
++#include <sys/stat.h>
+
+ #ifdef __TURBOC__
+ #include <io.h>
+diff -Naur umoria-5.6/source/signals.c umoria-5.6-aur/source/signals.c
+--- umoria-5.6/source/signals.c 2015-02-13 20:12:51.000000000 -0800
++++ umoria-5.6-aur/source/signals.c 2019-02-03 14:31:16.010231408 -0800
+@@ -24,6 +24,10 @@
+ /* To find out what system we're on. */
+
+ #include <stdio.h>
++#include <unistd.h>
++
++typedef void (*sighandler_t)(int);
++sighandler_t sysv_signal(int signum, sighandler_t handler);
+
+ #include "config.h"
+ #include "constant.h"
+@@ -126,9 +130,8 @@
+ #if defined(__TURBOC__) || defined(AMIGA)
+ static void signal_handler(sig)
+ #else
+-static int signal_handler(sig)
++static void signal_handler(int sig)
+ #endif
+-int sig;
+ {
+ #endif
+