summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormattiabiondi2018-11-11 00:36:36 +0100
committermattiabiondi2018-11-11 00:36:36 +0100
commitc4e2b45cf4a611f7df7278fe8f90d424897b677e (patch)
tree7cd451e12c4dbf0528c41edf805248405bd3f2eb
downloadaur-c4e2b45cf4a611f7df7278fe8f90d424897b677e.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9937ab5b9571
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = umps
+ pkgdesc = Virtual machine simulator based around the MIPS R2/3000 microprocessor.
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = http://mps.sourceforge.net/
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = libtool
+ makedepends = m4
+ makedepends = automake
+ makedepends = autoconf
+ depends = qt4
+ depends = libelf
+ depends = boost
+ depends = libsigc++
+
+pkgname = umps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8dfacc53a6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattia Biondi <mattia dot biondi3 at studio dot unibo dot it>
+pkgname=umps
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Virtual machine simulator based around the MIPS R2/3000
+microprocessor."
+arch=('x86_64')
+url="http://mps.sourceforge.net/"
+license=('GPL2')
+depends=('qt4' 'libelf' 'boost' 'libsigc++')
+makedepends=('git' 'libtool' 'm4' 'automake' 'autoconf')
+
+build() {
+ libtoolize --force
+ cd ..
+ aclocal
+ autoreconf -vfi
+ automake --force-missing --add-missing
+ autoconf
+ ./configure --enable-maintainer-mode --with-mips-tool-prefix=mipsel-linux-gnu-
+ make
+}
+
+check() {
+ make -k check
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+}