summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Biondi2020-06-20 13:01:37 +0200
committerMattia Biondi2020-06-20 13:01:37 +0200
commit4565f50319a6d29638157c5d7488d0abfe13aa15 (patch)
tree2479880f703d2f027f54a12958fc1041440e3d70
downloadaur-4565f50319a6d29638157c5d7488d0abfe13aa15.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5539946abaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = umps3-git
+ pkgdesc = Virtual machine simulator based around the MIPS R2/3000 microprocessor.
+ pkgver = 3.0.0.r0.g9099705
+ pkgrel = 1
+ url = https://github.com/virtualsquare/umps3
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = libelf
+ depends = boost
+ depends = libsigc++
+ depends = cross-mipsel-linux-gnu-gcc
+ conflicts = umps3
+ source = umps3-git::git+https://github.com/virtualsquare/umps3.git
+ sha256sums = SKIP
+
+pkgname = umps3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..940945c475d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mattia Biondi <mattia biondi1 at gmail dot com>
+_name=umps
+_ver=3
+pkgname=$_name$_ver-git
+pkgver=3.0.0.r0.g9099705
+pkgrel=1
+pkgdesc="Virtual machine simulator based around the MIPS R2/3000 microprocessor."
+arch=('x86_64')
+url="https://github.com/virtualsquare/umps3"
+license=('GPL3')
+depends=('qt5-base' 'libelf' 'boost' 'libsigc++' "cross-mipsel-linux-gnu-gcc")
+makedepends=('git' 'cmake')
+conflicts=("umps3")
+source=("$pkgname::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C $pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cmake -B build -S $pkgname \
+ -DCMAKE_BUILD_TYPE=Release
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir/" install
+}