summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorehs03292021-03-20 21:00:31 -0400
committerehs03292021-03-20 21:00:31 -0400
commit4246268953733427d5f200ae67e8964e107dc667 (patch)
tree5407d861524c5ce9817cdb74f493468b444b09f1
downloadaur-4246268953733427d5f200ae67e8964e107dc667.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9b04139ddb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = umpv
+ pkgdesc = mpv script that emulates "unique application" functionality on Linux
+ pkgver = 0.33.0
+ pkgrel = 1
+ url = https://github.com/mpv-player/mpv
+ arch = any
+ license = GPL
+ depends = mpv
+ depends = python
+ optdepends = youtube-dl
+ conflicts = mpv-tools
+ source = mpv-0.33.0.tar.gz::https://github.com/mpv-player/mpv/archive/v0.33.0.tar.gz
+ sha256sums = f1b9baf5dc2eeaf376597c28a6281facf6ed98ff3d567e3955c95bf2459520b4
+
+pkgname = umpv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a523f1e0aa2d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+mpv-*.tar.gz
+pkg/
+src/
+umpv-*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0a5e419d026
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Edward Springer <ehs0329 AT gmail DOT com>
+
+pkgname=umpv
+_srcname=mpv
+pkgver=0.33.0
+pkgrel=1
+pkgdesc="mpv script that emulates \"unique application\" functionality on Linux"
+arch=('any')
+url="https://github.com/mpv-player/mpv"
+license=('GPL')
+depends=('mpv' 'python')
+optdepends=('youtube-dl')
+conflicts=('mpv-tools')
+source=("$_srcname-$pkgver.tar.gz::https://github.com/mpv-player/$_srcname/archive/v$pkgver.tar.gz")
+sha256sums=('f1b9baf5dc2eeaf376597c28a6281facf6ed98ff3d567e3955c95bf2459520b4')
+
+package() {
+ cd "$_srcname-$pkgver/TOOLS"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+}