summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Cardace2015-10-06 09:14:57 +0200
committerAntonio Cardace2015-10-06 09:14:57 +0200
commitd918645e29e42ce87c91890d7c6e97f713865c35 (patch)
tree7ba753881854f58b7409dd17570c54e1b9f0508d
downloadaur-d918645e29e42ce87c91890d7c6e97f713865c35.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD53
-rw-r--r--umview-svn.install9
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f071ae947c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = umview-svn
+ pkgdesc = User-mode implementation of View-OS.
+ pkgver = r1129
+ pkgrel = 1
+ url = https://www.sourceforge.net/projects/view-os
+ install = umview-svn.install
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = make
+ makedepends = libtool
+ depends = glibc>=2.15
+ depends = libumlib0-svn
+ optdepends = umview-mod-umlwip-svn: module for umview networking
+ provides = umview-svn=r1129
+ conflicts = umview-svn
+ replaces = umview-svn
+ source = svn+http://svn.code.sf.net/p/view-os/code/trunk/xmview-os
+ source = umview-svn.install
+ md5sums = SKIP
+ md5sums = b4165e6142a92d65c8e14479486decc4
+
+pkgname = umview-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0caa8bfea988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Antonio Cardace <anto.cardace@gmail.com>
+pkgname=umview-svn
+pkgver=r1129
+pkgrel=1
+pkgdesc="User-mode implementation of View-OS."
+arch=('x86_64' 'i686')
+url="https://www.sourceforge.net/projects/view-os"
+license=('GPL2')
+depends=('glibc>=2.15'
+ 'libumlib0-svn')
+optdepends=('umview-mod-umlwip-svn: module for umview networking')
+makedepends=('autoconf' 'automake' 'make' 'libtool')
+provides=("$pkgname=$pkgver")
+conflicts=("$pkgname")
+replaces=("$pkgname")
+install="$pkgname.install"
+source=("svn+http://svn.code.sf.net/p/view-os/code/trunk/xmview-os"
+ "${pkgname}.install")
+md5sums=("SKIP"
+ "b4165e6142a92d65c8e14479486decc4")
+
+
+pkgver() {
+ cd "$srcdir/xmview-os"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build(){
+ cd "$srcdir/xmview-os"
+ autoreconf -i &> /dev/null
+ if [ "$CARCH" == "x86_64" ]; then
+ ./configure --prefix="${pkgdir}/usr" --disable-static
+ else
+ ./configure --prefix="${pkgdir}/usr" --libdir="${pkgdir}/usr/lib32" --disable-static
+ fi
+ make
+}
+
+package() {
+ #tar -xf data.tar.xz
+ #mkdir -p ${pkgdir}/usr/share/man
+ #cp -r usr/share/doc ${pkgdir}/usr/share
+ #cp -r usr/share/man/man2 ${pkgdir}/usr/share/man
+ #cp -r usr/share/man/man5 ${pkgdir}/usr/share/man
+ cd "$srcdir/xmview-os"
+ make install
+ if [ "$CARCH" == "x86_64" ]; then
+ rm -rf ${pkgdir}/usr/lib/libumlib*
+ else
+ rm -rf ${pkgdir}/usr/lib32/libumlib*
+ fi
+}
diff --git a/umview-svn.install b/umview-svn.install
new file mode 100644
index 000000000000..dc2ebedcdc56
--- /dev/null
+++ b/umview-svn.install
@@ -0,0 +1,9 @@
+post_install() {
+ set -e
+ ldconfig
+}
+
+post_remove() {
+ set -e
+ ldconfig
+}