summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2011-04-06 14:27:35 +0200
committerCedric Girard2011-04-06 14:27:35 +0200
commit23332fae111a06a7d4422cc3c73f1943257cc983 (patch)
treed9b85533f7055e1b38b9262543c8ec415c1adb9e
downloadaur-23332fae111a06a7d4422cc3c73f1943257cc983.tar.gz
The Unarchiver package. First version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--unarchiver-makefile.patch48
3 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d8e685c7503
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = unarchiver
+ pkgdesc = An Objective-C application for uncompressing archive files
+ pkgver = 2.6
+ pkgrel = 1
+ url = http://wakaba.c3.cx/s/apps/unarchiver.html
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ makedepends = gcc-objc
+ depends = gnustep-base
+ depends = openssl
+ depends = bzip2
+ depends = icu
+ depends = gcc-libs
+ depends = zlib
+ source = http://theunarchiver.googlecode.com/files/TheUnarchiver2.6_src.zip
+ source = unarchiver-makefile.patch
+ md5sums = 91144dcaf1d41ac5b38ae39eb6c3fea4
+ md5sums = 974025c5a7489409fbd101ee598f8dfd
+
+pkgname = unarchiver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a5b4be3f19f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+pkgname=unarchiver
+pkgver=2.6
+pkgrel=1
+pkgdesc="An Objective-C application for uncompressing archive files"
+arch=('x86_64' 'i686')
+url="http://wakaba.c3.cx/s/apps/unarchiver.html"
+license=('LGPL')
+depends=('gnustep-base' 'openssl' 'bzip2' 'icu' 'gcc-libs' 'zlib')
+makedepends=('gcc-objc')
+source=(http://theunarchiver.googlecode.com/files/TheUnarchiver"$pkgver"_src.zip unarchiver-makefile.patch)
+md5sums=('91144dcaf1d41ac5b38ae39eb6c3fea4'
+ '974025c5a7489409fbd101ee598f8dfd')
+
+build() {
+ cd "$srcdir/The Unarchiver/"
+
+ #remove unneeded and non LGPL compatible files
+ rm -rf "BadLicense" "The Unarchiver"
+
+ patch -p1 < ../../unarchiver-makefile.patch
+
+ cd XADMaster
+
+ . /opt/GNUstep/System/Library/Makefiles/GNUstep.sh
+ make -f Makefile.linux
+}
+
+package() {
+ cd "$srcdir/The Unarchiver/XADMaster"
+ install -d "$pkgdir/usr/bin/"
+ cp unar lsar "$pkgdir/usr/bin/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/unarchiver-makefile.patch b/unarchiver-makefile.patch
new file mode 100644
index 000000000000..574f73daaf4c
--- /dev/null
+++ b/unarchiver-makefile.patch
@@ -0,0 +1,48 @@
+diff -Naur The Unarchiver/UniversalDetector/Makefile.linux The Unarchiver_patched/UniversalDetector/Makefile.linux
+--- The Unarchiver/UniversalDetector/Makefile.linux 2010-07-10 16:32:50.000000000 +0200
++++ The Unarchiver_patched/UniversalDetector/Makefile.linux 2011-04-06 14:09:30.416074777 +0200
+@@ -16,7 +16,6 @@
+
+ GNUSTEP_OPTS = -DGNUSTEP \
+ -DGNU_RUNTIME=1 \
+- -D_NATIVE_OBJC_EXCEPTIONS \
+ -fgnu-runtime \
+ -fexceptions \
+ -fobjc-exceptions \
+@@ -27,7 +26,7 @@
+ -Wno-import \
+ -Wno-multichar \
+ -g \
+- -isystem /usr/include/GNUstep
++ -isystem /opt/GNUstep/Local/Library/Headers
+
+ OBJC_OPTS = -std=gnu99
+
+diff -Naur The Unarchiver/XADMaster/Makefile.linux The Unarchiver_patched/XADMaster/Makefile.linux
+--- The Unarchiver/XADMaster/Makefile.linux 2010-10-21 18:30:25.000000000 +0200
++++ The Unarchiver_patched/XADMaster/Makefile.linux 2011-04-06 14:10:32.927998010 +0200
+@@ -16,7 +16,6 @@
+
+ GNUSTEP_OPTS = -DGNUSTEP \
+ -DGNU_RUNTIME=1 \
+- -D_NATIVE_OBJC_EXCEPTIONS \
+ -fgnu-runtime \
+ -fexceptions \
+ -fobjc-exceptions \
+@@ -28,7 +27,7 @@
+ -Wno-multichar \
+ -g \
+ -D_FILE_OFFSET_BITS=64 \
+- -isystem /usr/include/GNUstep
++ -isystem /opt/GNUstep/Local/Library/Headers
+
+ OBJC_OPTS = -std=gnu99
+
+@@ -45,6 +44,7 @@
+ # Options for linking
+
+ LIBS = -Wl,--no-whole-archive \
++ -L/opt/GNUstep/Local/Library/Libraries \
+ -lgnustep-base \
+ -lcrypto \
+ -lbz2 \