summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2017-03-16 22:25:30 +1100
committerJoshua Hardy2017-03-16 22:25:30 +1100
commit001e477c5401427ab6f47f723e4a17288cc34849 (patch)
treeb5724ccdddd86a047d303f51a3dd1d7c1bbc0cb9
downloadaur-001e477c5401427ab6f47f723e4a17288cc34849.tar.gz
first upload
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD26
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52edf921d559
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = unblur
+ pkgdesc = Aligns the frames of movies recorded on an electron microscope to reduce image blurring due to beam-induced motion
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://grigoriefflab.janelia.org/unblur
+ arch = x86_64
+ license = custom
+ depends = gnuplot
+ depends = pdftk
+ depends = julia
+ optdepends = summovie: uses alignment results to calculate movie frame sums
+ source = http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/unblur_1.0.2.tar.gz
+ source = LICENSE
+ md5sums = b6e367061cd0cef1b62a391a6289f681
+ md5sums = SKIP
+
+pkgname = unblur
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9d8c11215816
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The Janelia Farm Research Campus Software Copyright 1.1
+
+Copyright (c) 2014, Howard Hughes Medical Institute, All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that
+the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this list of conditions and the
+following disclaimer.
+Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
+following disclaimer in the documentation and/or other materials provided with the distribution.
+Neither the name of the Howard Hughes Medical Institute nor the names of its contributors may be used to
+endorse or promote products derived from this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; REASONABLE ROYALTIES;
+OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5c1178ed7ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
+pkgname=unblur
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Aligns the frames of movies recorded on an electron microscope to reduce image blurring due to beam-induced motion"
+arch=(x86_64)
+url="http://grigoriefflab.janelia.org/unblur"
+license=('custom')
+depends=('gnuplot' 'pdftk' 'julia')
+optdepends=('summovie: uses alignment results to calculate movie frame sums')
+source=("http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/unblur_${pkgver}.tar.gz" "LICENSE")
+md5sums=('b6e367061cd0cef1b62a391a6289f681' 'SKIP')
+options=()
+
+prepare () {
+ echo "Unblur was written by Timothy Grant and Alexis Rohou and is subject to Janelia Farm Research Campus Software Copyright 1.1."
+}
+#build() {
+#}
+
+package() {
+ cd "${srcdir}/unblur_${pkgver}/bin"
+ install -d $pkgdir/usr/bin/ "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m755 * $pkgdir/usr/bin/.
+ install -D -m644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}