summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-08-13 21:07:24 -0400
committerJean Lucas2019-08-13 21:07:24 -0400
commitc76f9e656bb4ad603fb2e66900a118a4d099a157 (patch)
tree3aabfd9912ffb4289ec1132e7cee3a5c021faa53
parent1d970d17527b8e772e9b33e9dfc74a93f9bdd554 (diff)
downloadaur-c76f9e656bb4ad603fb2e66900a118a4d099a157.tar.gz
Add git to makedepends, update pkgver schema
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b9e1db5650c..47ecbd8381a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = unbound-block-hosts
- pkgdesc = Script to convert an ad-blocking hosts file (Dan Pollock's, by default) into Unbound local-data
- pkgver = 0+21+87966ee
- pkgrel = 2
+ pkgdesc = Script to convert an ad-blocking hosts file into Unbound local-data
+ pkgver = 0+r21+87966ee
+ pkgrel = 1
url = https://github.com/gbxyz/unbound-block-hosts
arch = any
license = GPL
license = PerlArtistic
+ makedepends = git
depends = perl-lwp-protocol-https
source = git+https://github.com/gbxyz/unbound-block-hosts#commit=87966ee571cdeb78b89d16aac48d8fa2935ad6b2
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 722491335ca4..03ae67c1add5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=unbound-block-hosts
-pkgver=0+21+87966ee
+pkgver=0+r21+87966ee
_commit=87966ee571cdeb78b89d16aac48d8fa2935ad6b2
-pkgrel=2
-pkgdesc="Script to convert an ad-blocking hosts file (Dan Pollock's, by default) into Unbound local-data"
+pkgrel=1
+pkgdesc='Script to convert an ad-blocking hosts file into Unbound local-data'
arch=(any)
url=https://github.com/gbxyz/unbound-block-hosts
license=(GPL PerlArtistic)
depends=(perl-lwp-protocol-https)
+makedepends=(git)
source=(git+$url#commit=$_commit)
sha512sums=('SKIP')
pkgver() {
cd $pkgname
- printf 0+%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+ printf 0+r%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
}
package() {