summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-04-15 23:29:49 -0400
committerJean Lucas2019-04-15 23:33:37 -0400
commitfc54df26f83e83e8c1528b4a61481800052a1f33 (patch)
treee729a280910168fe34271d97cf675d722a238a0b
downloadaur-fc54df26f83e83e8c1528b4a61481800052a1f33.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..555b85f91524
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Tue Apr 16 03:33:32 UTC 2019
+pkgbase = unbound-block-hosts
+ pkgdesc = Script to convert an ad-blocking hosts file (Dan Pollock's, by default) into Unbound local-data
+ pkgver = 0+21+87966ee
+ pkgrel = 1
+ url = https://github.com/gbxyz/unbound-block-hosts
+ arch = any
+ license = GPL
+ depends = perl
+ source = git+https://github.com/gbxyz/unbound-block-hosts#commit=87966ee571cdeb78b89d16aac48d8fa2935ad6b2
+ sha512sums = SKIP
+
+pkgname = unbound-block-hosts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ad73331d378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=unbound-block-hosts
+pkgver=0+21+87966ee
+_commit=87966ee571cdeb78b89d16aac48d8fa2935ad6b2
+pkgrel=1
+pkgdesc="Script to convert an ad-blocking hosts file (Dan Pollock's, by default) into Unbound local-data"
+arch=(any)
+url=https://github.com/gbxyz/unbound-block-hosts
+license=(GPL)
+depends=(perl)
+source=(git+$url#commit=$_commit)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf 0+%s+%s $(git rev-list --count HEAD) $(git rev-parse --short HEAD)
+}
+
+package() {
+ cd $pkgname
+ install -D unbound-block-hosts -t "$pkgdir"/usr/bin
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/unbound-block-hosts
+}