summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Wagner2015-06-29 11:55:47 -0400
committerAndreas Wagner2015-06-29 11:55:47 -0400
commit04ec279d3b6b59386a6e70deef0f8322bbc86c2d (patch)
tree394f4b888f8bec95b24b78e893e5ae1d22486309
downloadaur-04ec279d3b6b59386a6e70deef0f8322bbc86c2d.tar.gz
Initial import.
-rw-r--r--.SRCINFO15
-rw-r--r--ChangeLog28
-rw-r--r--PKGBUILD30
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6dd66675899
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = unbuffered
+ pkgdesc = Copy stdin to stdout and stderr, unbuffered
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = http://www.scylla-charybdis.com/tool.php/unbuffered
+ changelog = ChangeLog
+ arch = i686
+ arch = x86_64
+ license = GPL2+
+ depends = glibc
+ source = unbuffered-0.5.2::git+https://github.com/hilbix/unbuffered.git#commit=f3004614e5da8bcdec2007c0eb98a61c5101ea20
+ sha512sums = SKIP
+
+pkgname = unbuffered
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..7779983662d4
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,28 @@
+2012-02-23 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 0.3.0-1 :
+ Updated to the latest version.
+
+
+2011-02-26 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 0.2.0-1 :
+ Updated to the latest version.
+
+
+2009-07-05 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 0.1.0-1 :
+ Updated to the latest version.
+
+
+2009-05-21 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 0.0.2-2 :
+ Replaced in my '# Contributor:' line by '# Maintainer:'
+
+
+2009-02-28 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+ * 0.0.2-1 :
+ Initial release.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd41fd76006
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Andreas Wagner <AndreasBWagner@pointfree.net>
+# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
+
+pkgname=unbuffered
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="Copy stdin to stdout and stderr, unbuffered"
+arch=('i686' 'x86_64')
+url="http://www.scylla-charybdis.com/tool.php/${pkgname}"
+license=('GPL2+')
+depends=('glibc')
+changelog='ChangeLog'
+source=(${pkgname}-${pkgver}::'git+https://github.com/hilbix/unbuffered.git#commit=f3004614e5da8bcdec2007c0eb98a61c5101ea20')
+sha512sums=('SKIP')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ git submodule update --init
+ make ${pkgname}_version.h
+ sed -i 's/\r//' $srcdir/${pkgname}-${pkgver}/unbuffered_version.h
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ mkdir -p $pkgdir/usr/bin
+ make INSTALLPATH=$pkgdir/usr install
+}
+
+# vim:set ts=2 sw=2 et: