summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlwyn Kik2019-04-23 14:03:14 +0200
committerAlwyn Kik2019-04-23 14:03:14 +0200
commitd6e06e211418070731f92b0e0972c79d444b124d (patch)
tree3e18f40f05a824547a71d77beb4c5935de8d92d0
parent04ec279d3b6b59386a6e70deef0f8322bbc86c2d (diff)
downloadaur-d6e06e211418070731f92b0e0972c79d444b124d.tar.gz
Use latest git version
-rw-r--r--.gitignore3
-rw-r--r--ChangeLog4
-rw-r--r--PKGBUILD18
3 files changed, 17 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d772f6e0cc65
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+unbuffered-git-r*
diff --git a/ChangeLog b/ChangeLog
index 7779983662d4..b98e2403f135 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2019-04-23 Alwyn Kik <alwyn@proteon.com>
+ * develop :
+ Updated to the latest commit
+
2012-02-23 Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
* 0.3.0-1 :
diff --git a/PKGBUILD b/PKGBUILD
index 8dd41fd76006..0c0b4088838e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
-# Maintainer: Andreas Wagner <AndreasBWagner@pointfree.net>
+# Maintainer: Alwyn Kik <alwyn@proteon.com>
+# Contributor: Andreas Wagner <AndreasBWagner@pointfree.net>
# Contributor: Gerardo Exequiel Pozzi <vmlinuz386@yahoo.com.ar>
-pkgname=unbuffered
-pkgver=0.5.2
+pkgname=unbuffered-git
+pkgver=r1.f73865a
pkgrel=1
-pkgdesc="Copy stdin to stdout and stderr, unbuffered"
+pkgdesc="Copy stdin to stdout and stderr, unbuffered, development version"
arch=('i686' 'x86_64')
url="http://www.scylla-charybdis.com/tool.php/${pkgname}"
-license=('GPL2+')
+license=('GPL2')
depends=('glibc')
-changelog='ChangeLog'
-source=(${pkgname}-${pkgver}::'git+https://github.com/hilbix/unbuffered.git#commit=f3004614e5da8bcdec2007c0eb98a61c5101ea20')
+makedepends=('git')
+changelog=ChangeLog
+source=(${pkgname}-${pkgver}::'git+https://github.com/hilbix/unbuffered.git#commit=f73865a6cd253052312b154ca4c2e9e1e2f5ce47')
sha512sums=('SKIP')
build() {
cd "$srcdir/${pkgname}-${pkgver}"
git submodule update --init
- make ${pkgname}_version.h
+ make unbuffered_version.h
sed -i 's/\r//' $srcdir/${pkgname}-${pkgver}/unbuffered_version.h
make
}