summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaruman92016-06-15 09:54:22 +0300
committersaruman92016-06-15 09:54:22 +0300
commit550745ce1e3a1fcfe205c6f454ccc6a791ed9750 (patch)
treeaf2bfcb5ca6669e54a0add90f61aba94a8d8c592
downloadaur-550745ce1e3a1fcfe205c6f454ccc6a791ed9750.tar.gz
Initial commit. Version: 4.0.833-1
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD44
-rw-r--r--understand4
-rw-r--r--understand.desktop11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9338b06a2372
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = understand-bin
+ pkgdesc = Static analysis tool for maintaining, measuring & analyzing critical or large code bases.
+ pkgver = 4.0.833
+ pkgrel = 1
+ url = https://scitools.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxext
+ depends = libtinfo5
+ options = !strip
+ options = !upx
+ source_i686 = http://builds.scitools.com/all_builds/b833/Understand/Understand-4.0.833-Linux-32bit.tgz
+ source_i686 = understand.desktop
+ source_i686 = understand
+ md5sums_i686 = f4fa953527c0f71e831f5bb44739c567
+ md5sums_i686 = 86ea741c38198d7291d5126ef0cd17f8
+ md5sums_i686 = 2927bc21f24ff8776a1c601379c9f19f
+ source_x86_64 = http://builds.scitools.com/all_builds/b833/Understand/Understand-4.0.833-Linux-64bit.tgz
+ source_x86_64 = understand.desktop
+ source_x86_64 = understand
+ md5sums_x86_64 = 1684d8f63bc8925460529992cdced458
+ md5sums_x86_64 = 86ea741c38198d7291d5126ef0cd17f8
+ md5sums_x86_64 = 2927bc21f24ff8776a1c601379c9f19f
+
+pkgname = understand-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71faf0ac5e68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alex Sarum <rum.274.4 at gmail dot com>
+
+_pkgname=understand
+pkgname=$_pkgname-bin
+_pkgbuild=833
+pkgver=4.0.$_pkgbuild
+pkgrel=1
+pkgdesc="Static analysis tool for maintaining, measuring & analyzing critical or large code bases."
+arch=('i686' 'x86_64')
+url="https://scitools.com/"
+license=('custom')
+depends=('libx11' 'libxau' 'libxcb' 'libxdmcp' 'libxext' 'libtinfo5')
+options=('!strip' '!upx')
+
+source_i686=("http://builds.scitools.com/all_builds/b$_pkgbuild/${_pkgname^}/${_pkgname^}-$pkgver-Linux-32bit.tgz"
+"$_pkgname.desktop"
+"$_pkgname")
+
+source_x86_64=("http://builds.scitools.com/all_builds/b$_pkgbuild/${_pkgname^}/${_pkgname^}-$pkgver-Linux-64bit.tgz"
+"$_pkgname.desktop"
+"$_pkgname")
+md5sums_i686=('f4fa953527c0f71e831f5bb44739c567'
+ '86ea741c38198d7291d5126ef0cd17f8'
+ '2927bc21f24ff8776a1c601379c9f19f')
+md5sums_x86_64=('1684d8f63bc8925460529992cdced458'
+ '86ea741c38198d7291d5126ef0cd17f8'
+ '2927bc21f24ff8776a1c601379c9f19f')
+
+
+package() {
+ _source_arch="32"
+ [ "$CARCH" = "x86_64" ] && _source_arch="64"
+
+ install -d "$pkgdir/opt"
+ cp -r "$srcdir/scitools" "$pkgdir/opt/"
+
+ [ "$CARCH" = "x86_64" ] && sed -i s/linux32/linux64/ understand
+ install -Dm755 "$srcdir/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -Dm644 "$pkgdir/opt/scitools/bin/linux$_source_arch/${_pkgname}_64.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+
+ install -Dm644 "$pkgdir/opt/scitools/conf/license/readme.txt" "$pkgdir/usr/share/licenses/$pkgname/readme.txt"
+}
diff --git a/understand b/understand
new file mode 100644
index 000000000000..e8922bfab26e
--- /dev/null
+++ b/understand
@@ -0,0 +1,4 @@
+#!/bin/bash
+export LD_LIBRARY_PATH=/opt/scitools/bin/linux32
+unset QT_PLUGIN_PATH
+/opt/scitools/bin/linux32/understand.bin "$@"
diff --git a/understand.desktop b/understand.desktop
new file mode 100644
index 000000000000..7e8cd80ba652
--- /dev/null
+++ b/understand.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Understand
+Version=1.0
+Exec=/usr/bin/understand
+Icon=understand
+Type=Application
+Terminal=false
+Comment=Analyze it, measure it, visualize it, maintain it - Understand it
+Comment[ru]=Статический анализатор кода
+GenericName=Static analysis tool
+Categories=Development;IDE; \ No newline at end of file