summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-07 17:34:54 +1300
committercaltlgin2020-10-07 17:34:54 +1300
commit32e8b8d0e8969f92697fc9e576d6180c31b25cff (patch)
tree4499f3dbade197b6ab7456a31ce7ce1e17c024e5
downloadaur-32e8b8d0e8969f92697fc9e576d6180c31b25cff.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6be8c707fd9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = undocker
+ pkgdesc = Extract Docker images
+ pkgver = 7
+ pkgrel = 1
+ url = https://github.com/larsks/undocker/
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/u/undocker/undocker-7.tar.gz
+ sha256sums = f098bd429a5a7bf08730069388cda2c14612f69eae0af4f27367f2cb8c9e4254
+
+pkgname = undocker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..019e3af4b841
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='undocker'
+pkgver=7
+pkgrel=1
+pkgdesc='Extract Docker images'
+arch=('any')
+url='https://github.com/larsks/undocker/'
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f098bd429a5a7bf08730069388cda2c14612f69eae0af4f27367f2cb8c9e4254')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+}
+
+# vim: ts=2 sw=2 et: