summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrm 212021-07-01 02:59:46 +0000
committergrm 212021-07-01 03:12:42 +0000
commit4402fb40f0968d5252f1d4f407b61e9928812f93 (patch)
tree5acfadd779aec47b53b0ccc02421e4cffb4b19c0
downloadaur-4402fb40f0968d5252f1d4f407b61e9928812f93.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--undollar-1.0.0.tgzbin0 -> 2271 bytes
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5dc04d0d8a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = undollar
+ pkgdesc = undollar strips the dollar sign from the beginning of the terminal command you just copied from StackOverflow
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/xtyrrell/undollar
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ noextract = undollar-1.0.0.tgz
+ source = https://registry.npmjs.org/undollar/-/undollar-1.0.0.tgz
+ sha256sums = 561a2d2780c8bb912a5fc1499f7c16b9bfd5320af68a7a844515fe66d3de7dd0
+
+pkgname = undollar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90dda5aa6210
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: gr m21 <grm21@protonmail.com>
+_npmname=undollar
+pkgname=undollar
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="undollar strips the dollar sign from the beginning of the terminal command you just copied from StackOverflow"
+arch=(any)
+url="https://github.com/xtyrrell/undollar"
+license=(MIT)
+depends=('nodejs' 'npm')
+source=("https://registry.npmjs.org/$_npmname/-/$_npmname-$pkgver.tgz")
+noextract=("$_npmname-$pkgver.tgz")
+sha256sums=('561a2d2780c8bb912a5fc1499f7c16b9bfd5320af68a7a844515fe66d3de7dd0')
+
+package() {
+ cd "$srcdir"
+ local _npmdir="$pkgdir/usr/lib/node_modules/"
+ mkdir -p "$_npmdir"
+ cd "$_npmdir"
+ npm install -g --prefix "$pkgdir/usr" "$srcdir/$_npmname-$pkgver.tgz"
+ install -Dm644 "$pkgdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Fix NPM racecondition, also known as derp
+ find "$pkgdir/usr" -type d -exec chmod 755 '{}' +
+}
diff --git a/undollar-1.0.0.tgz b/undollar-1.0.0.tgz
new file mode 100644
index 000000000000..c484befb2ac3
--- /dev/null
+++ b/undollar-1.0.0.tgz
Binary files differ