summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-05 17:40:41 +0100
committerBartłomiej Piotrowski2018-01-05 17:40:41 +0100
commit325376b047a38625f182d600d8e8a61ff0567520 (patch)
tree24d0872405ed3a7b85f3df81212bf82dae260816
downloadaur-325376b047a38625f182d600d8e8a61ff0567520.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD62
-rw-r--r--org.archlinux.pkexec.unetbootin.policy18
-rw-r--r--unetbootin.sh11
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bb70e22cd99
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = unetbootin
+ pkgdesc = Create bootable Live USB drives
+ pkgver = 657
+ pkgrel = 1
+ url = https://unetbootin.github.io
+ arch = x86_64
+ license = GPL
+ makedepends = setconf
+ depends = syslinux
+ depends = p7zip
+ depends = qt4
+ depends = mtools
+ depends = zenity
+ optdepends = polkit: run unetbootin directly from menu
+ optdepends = zenity: display an error if no authentication agent is found
+ source = unetbootin-657.tar.gz::https://github.com/unetbootin/unetbootin/archive/657.tar.gz
+ source = org.archlinux.pkexec.unetbootin.policy
+ source = unetbootin.sh
+ sha256sums = e091904e455aebc7b3d22d6cb3363c51796b6b9bec59389c9d4ecad54c7febee
+ sha256sums = fa9bb53d90cb10a0ab8dd317ed6a3506b228b0e26ed2ed8b108b5990f641641a
+ sha256sums = 6399c6a44b270a4ec67a36e3914c7c2f47a9008efb0133a33f92d9ad4284cc57
+
+pkgname = unetbootin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82c7296ab44e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# $Id: PKGBUILD 272215 2017-12-05 08:22:43Z arojas $
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Det <nimetonmaili@gmail.com>
+# Contributor: Godane aka Christopher Rogers <slaxemulator@gmail.com>
+# Contributor: Michai Coman <mihai@m1x.ro>
+
+pkgname=unetbootin
+pkgver=657
+pkgrel=1
+arch=('x86_64')
+license=('GPL')
+pkgdesc='Create bootable Live USB drives'
+url='https://unetbootin.github.io'
+depends=('syslinux' 'p7zip' 'qt4' 'mtools' 'zenity')
+makedepends=('setconf')
+optdepends=('polkit: run unetbootin directly from menu'
+ 'zenity: display an error if no authentication agent is found')
+source=($pkgname-$pkgver.tar.gz::"https://github.com/unetbootin/unetbootin/archive/$pkgver.tar.gz"
+ 'org.archlinux.pkexec.unetbootin.policy'
+ 'unetbootin.sh')
+sha256sums=('e091904e455aebc7b3d22d6cb3363c51796b6b9bec59389c9d4ecad54c7febee'
+ 'fa9bb53d90cb10a0ab8dd317ed6a3506b228b0e26ed2ed8b108b5990f641641a'
+ '6399c6a44b270a4ec67a36e3914c7c2f47a9008efb0133a33f92d9ad4284cc57')
+
+prepare() {
+ cd $pkgname-$pkgver/src/unetbootin
+
+ setconf unetbootin.desktop Exec /usr/bin/unetbootin
+}
+
+build() {
+ cd $pkgname-$pkgver/src/$pkgname
+
+ ./build-nostatic
+}
+
+package() {
+ cd $pkgname-$pkgver/src/$pkgname
+
+ install -d "$pkgdir/usr/share/$pkgname"
+ install -m644 "$pkgname"_*.qm "$pkgdir/usr/share/$pkgname/"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname.elf"
+
+ # Application shortcut
+ install -Dm644 "$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ for i in 16 22 24 32 48 256; do
+ install -Dm644 "${pkgname}_${i}.png" \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ done
+
+ cd "$srcdir"
+
+ install -m755 "${pkgname}.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # Polkit policy
+ install -Dm644 'org.archlinux.pkexec.unetbootin.policy' \
+ "$pkgdir/usr/share/polkit-1/actions/org.archlinux.pkexec.unetbootin.policy"
+}
+
+# getver: -u 3 packages.gentoo.org/packages/sys-boot/unetbootin
+# vim:set ts=2 sw=2 et:
diff --git a/org.archlinux.pkexec.unetbootin.policy b/org.archlinux.pkexec.unetbootin.policy
new file mode 100644
index 000000000000..c17df4ad6e5b
--- /dev/null
+++ b/org.archlinux.pkexec.unetbootin.policy
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE policyconfig PUBLIC
+ "-//freedesktop//DTD PolicyKit Policy Configuration 1.0//EN"
+ "http://www.freedesktop.org/standards/PolicyKit/1/policyconfig.dtd">
+<policyconfig>
+ <action id="org.archlinux.pkexec.unetbootin">
+ <message>Authentication is required to run Unetbootin</message>
+ <icon_name>unetbootin</icon_name>
+ <defaults>
+ <allow_any>auth_admin</allow_any>
+ <allow_inactive>auth_admin</allow_inactive>
+ <allow_active>auth_admin</allow_active>
+ </defaults>
+ <annotate key="org.freedesktop.policykit.exec.path">/usr/bin/unetbootin.elf</annotate>
+ <annotate key="org.freedesktop.policykit.exec.allow_gui">true</annotate>
+ </action>
+</policyconfig>
+
diff --git a/unetbootin.sh b/unetbootin.sh
new file mode 100644
index 000000000000..89f840428928
--- /dev/null
+++ b/unetbootin.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+export QT_X11_NO_MITSHM=1
+if [ $(which pkexec) ]; then
+ pkexec --disable-internal-agent "/usr/bin/unetbootin.elf" "$@" 2>/tmp/_polkit_error
+ if [ -s /tmp/_polkit_error ]; then
+ zenity --error --text="`cat /tmp/_polkit_error`"
+ rm /tmp/_polkit_error
+ fi
+else
+ /usr/bin/unetbootin.elf "$@"
+fi