summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-02 14:29:37 +1300
committercaltlgin2020-11-02 14:29:37 +1300
commit0cac6f1a19ce32be3ec16f10d2bf10fe0fa07c5a (patch)
tree56c61171f43ff32a21e2a88bbb5365d6268941a8
parentd98b84aebc0f9a5c0b6aed01451883f349208c91 (diff)
downloadaur-0cac6f1a19ce32be3ec16f10d2bf10fe0fa07c5a.tar.gz
Add makedepens=('qt5-tools')
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b388c7c31337..14aa0d9001fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = unetbootin-git
pkgdesc = Create bootable Live USB drives
pkgver = 681.r16.g28ffb108
- pkgrel = 1
+ pkgrel = 2
url = https://unetbootin.github.io
arch = x86_64
license = GPL3
makedepends = git
makedepends = setconf
+ makedepends = qt5-tools
depends = mtools
depends = p7zip
depends = qt5-base
diff --git a/PKGBUILD b/PKGBUILD
index 2110ef9e0f2f..ef25cff12743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,18 @@
_pkgname='unetbootin'
pkgname="${_pkgname}-git"
pkgver=681.r16.g28ffb108
-pkgrel=1
+pkgrel=2
pkgdesc='Create bootable Live USB drives'
arch=('x86_64')
url='https://unetbootin.github.io'
_url_source='https://github.com/unetbootin/unetbootin'
license=('GPL3')
depends=('mtools' 'p7zip' 'qt5-base' 'syslinux')
-makedepends=('git' 'setconf')
+makedepends=('git' 'setconf' 'qt5-tools')
optdepends=('polkit: run unetbootin directly from menu')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
+# NB: git repo size ~470MB
source=("git+${_url_source}.git"
"${_pkgname}.sh"
"org.archlinux.pkexec.${_pkgname}.policy")
@@ -39,8 +40,8 @@ pkgver() {
build() {
cd "${_pkgname}/src/${_pkgname}"
- lupdate "${_pkgname}.pro"
- lrelease "${_pkgname}.pro"
+ lupdate-qt5 "${_pkgname}.pro"
+ lrelease-qt5 "${_pkgname}.pro"
qmake-qt5 "${_pkgname}.pro" -config release "DEFINES += NOSTATIC" "RESOURCES -= ${_pkgname}.qrc"
make
}