summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2020-07-30 21:13:09 +0300
committergardenapple2020-07-30 21:13:09 +0300
commitb37b3fdfbcb117b2c2e296693fa7a2542b801180 (patch)
tree70c89482beab8eae089b5d4681383788ca061913
parentd83f4e540faf9a8be7eb8dd1d3914a35fdf741a9 (diff)
downloadaur-b37b3fdfbcb117b2c2e296693fa7a2542b801180.tar.gz
Qt5 fork + patch
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD61
-rw-r--r--remove-qt-x11-no-mitshm.patch22
-rw-r--r--unetbootin.sh5
5 files changed, 86 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7aec92b9d5d..00655379406b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,32 @@
-pkgbase = unetbootin
- pkgdesc = Create bootable Live USB drives
- pkgver = 681
+pkgbase = unetbootin-qt5-git
+ pkgdesc = Create bootable Live USB drives (Qt5 fork)
+ pkgver = 655.r4.g9cc0841
pkgrel = 1
url = https://unetbootin.github.io
arch = x86_64
license = GPL
- makedepends = setconf
+ makedepends = git
+ makedepends = qt5-tools
depends = syslinux
depends = p7zip
- depends = qt4
+ depends = qt5-base
depends = mtools
depends = zenity
optdepends = polkit: run unetbootin directly from menu
optdepends = zenity: display an error if no authentication agent is found
- source = https://github.com/unetbootin/unetbootin/archive/681.tar.gz
+ provides = unetbootin
+ source = unetbootin-qt5-git::git+https://github.com/Chemrat/unetbootin.git
source = org.archlinux.pkexec.unetbootin.policy
+ source = remove-qt-x11-no-mitshm.patch
source = unetbootin.sh
- sha256sums = ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a
+ sha256sums = SKIP
sha256sums = fa9bb53d90cb10a0ab8dd317ed6a3506b228b0e26ed2ed8b108b5990f641641a
- sha256sums = 6399c6a44b270a4ec67a36e3914c7c2f47a9008efb0133a33f92d9ad4284cc57
+ sha256sums = 50595cb9ee105d422d35aba8ec17b67395226220c59d928a4c0761ac11ca3de8
+ sha256sums = 0ab2d1d37a0ec9021a6c610209755c7551ac0eb1d8b50c74d61fc3bb3b14fe5d
+ b2sums = SKIP
+ b2sums = 4aa0788a91c6326ebe07ea7cd814d1907b3615bb25c8dd4658253254a2bec18817835937e59a5a30bc39b62abbb4a1e30d0abc81e3441e5ad1cbea94b95e2348
+ b2sums = 1dacbc91e2b2784ebe01ffb2288c30113d10ece136bccce7e7cac12fec7c2926990be3130f4da5da3c9561a06dbcff4feed21e1951ce95926c491439862ea12c
+ b2sums = 28304c8a089febd75cdd075e69a53bb41fc9f8d81a0aad7acbef0ec879c4c834ff78b25d9b306555dbfb8367f8aa7ff6ca3c90ca14e9fda379e494cb847bcdb3
-pkgname = unetbootin
+pkgname = unetbootin-qt5-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a4f6e835bcd9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+src/
+pkg/
+unetbootin-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index e7eecc74dc6d..f9440e760fdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,77 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Yurii <yu.hrysh@posteo.net>
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Det <nimetonmaili@gmail.com>
# Contributor: Godane aka Christopher Rogers <slaxemulator@gmail.com>
# Contributor: Michai Coman <mihai@m1x.ro>
-pkgname=unetbootin
-pkgver=681
+pkgname=unetbootin-qt5-git
+_pkgname=unetbootin
+pkgver=655.r4.g9cc0841
pkgrel=1
arch=('x86_64')
license=('GPL')
-pkgdesc='Create bootable Live USB drives'
+pkgdesc='Create bootable Live USB drives (Qt5 fork)'
url='https://unetbootin.github.io'
-depends=('syslinux' 'p7zip' 'qt4' 'mtools' 'zenity')
-makedepends=('setconf')
+depends=('syslinux' 'p7zip' 'qt5-base' 'mtools' 'zenity')
+makedepends=('git' 'qt5-tools')
+provides=('unetbootin')
optdepends=('polkit: run unetbootin directly from menu'
'zenity: display an error if no authentication agent is found')
-source=("https://github.com/unetbootin/unetbootin/archive/${pkgver}.tar.gz"
+source=("${pkgname}::git+https://github.com/Chemrat/unetbootin.git"
'org.archlinux.pkexec.unetbootin.policy'
+ 'remove-qt-x11-no-mitshm.patch'
'unetbootin.sh')
-sha256sums=('ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a'
+sha256sums=('SKIP'
'fa9bb53d90cb10a0ab8dd317ed6a3506b228b0e26ed2ed8b108b5990f641641a'
- '6399c6a44b270a4ec67a36e3914c7c2f47a9008efb0133a33f92d9ad4284cc57')
+ '50595cb9ee105d422d35aba8ec17b67395226220c59d928a4c0761ac11ca3de8'
+ '0ab2d1d37a0ec9021a6c610209755c7551ac0eb1d8b50c74d61fc3bb3b14fe5d')
+b2sums=('SKIP'
+ '4aa0788a91c6326ebe07ea7cd814d1907b3615bb25c8dd4658253254a2bec18817835937e59a5a30bc39b62abbb4a1e30d0abc81e3441e5ad1cbea94b95e2348'
+ '1dacbc91e2b2784ebe01ffb2288c30113d10ece136bccce7e7cac12fec7c2926990be3130f4da5da3c9561a06dbcff4feed21e1951ce95926c491439862ea12c'
+ '28304c8a089febd75cdd075e69a53bb41fc9f8d81a0aad7acbef0ec879c4c834ff78b25d9b306555dbfb8367f8aa7ff6ca3c90ca14e9fda379e494cb847bcdb3')
prepare() {
- cd "${pkgname}-${pkgver}/src/${pkgname}"
+ cd "${pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/remove-qt-x11-no-mitshm.patch"
+ cd "src/unetbootin"
+
+ # Use Qt5 build tools instead
+ sed -i -e 's/-qt4/-qt5/g' build-nostatic
- setconf unetbootin.desktop Exec /usr/bin/unetbootin
}
build() {
- cd "${pkgname}-${pkgver}/src/${pkgname}"
+ cd "${pkgname}/src/unetbootin"
./build-nostatic
}
+# Using the most recent un-annotated tag (name does not contain dashes)
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
package() {
- cd "${pkgname}-${pkgver}/src/${pkgname}"
+ cd "${pkgname}/src/unetbootin"
- install -d "${pkgdir}/usr/share/${pkgname}"
- install -m644 "${pkgname}"_*.qm "${pkgdir}/usr/share/${pkgname}/"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}.elf"
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+ install -m644 unetbootin_*.qm "${pkgdir}/usr/share/${_pkgname}/"
+ install -Dm755 unetbootin "${pkgdir}/usr/bin/${_pkgname}.elf"
# Application shortcut
- install -Dm644 "${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 unetbootin.desktop \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
for i in 16 22 24 32 48 256; do
- install -Dm644 "${pkgname}_${i}.png" \
- "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${pkgname}.png"
+ install -Dm644 "unetbootin_${i}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${i}x${i}/apps/${_pkgname}.png"
done
cd "$srcdir"
- install -m755 "${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -m755 "unetbootin.sh" "${pkgdir}/usr/bin/${_pkgname}"
# Polkit policy
install -Dm644 'org.archlinux.pkexec.unetbootin.policy' \
diff --git a/remove-qt-x11-no-mitshm.patch b/remove-qt-x11-no-mitshm.patch
new file mode 100644
index 000000000000..af9a947591a8
--- /dev/null
+++ b/remove-qt-x11-no-mitshm.patch
@@ -0,0 +1,22 @@
+diff --git a/src/unetbootin/main.cpp b/src/unetbootin/main.cpp
+index 1ef73048..965bdca6 100644
+--- a/src/unetbootin/main.cpp
++++ b/src/unetbootin/main.cpp
+@@ -296,7 +296,7 @@ int main(int argc, char **argv)
+ argsconcSingleQuote += "'rootcheck=no'";
+ #ifdef Q_OS_LINUX
+ QString gksuarg1;
+- gksuarg1 += QString("bash -c 'QT_X11_NO_MITSHM=1 ");
++ gksuarg1 += QString("bash -c ' ");
+ gksuarg1 += QString("%1 %2").arg(app.applicationFilePath()).arg(argsconc);
+ gksuarg1 += QString("'");
+ QStringList gksuargs;
+@@ -343,7 +343,7 @@ int main(int argc, char **argv)
+ rootmsgb.setIcon(QMessageBox::Warning);
+ rootmsgb.setWindowTitle(uninstaller::tr("Must run as root"));
+ rootmsgb.setTextFormat(Qt::RichText);
+- rootmsgb.setText(uninstaller::tr("%2 must be run as root. Close it, and re-run using either:<br/><b>sudo QT_X11_NO_MITSHM=1 %1</b><br/>or:<br/><b>su -c 'QT_X11_NO_MITSHM=1 %1'</b>").arg(app.applicationFilePath()).arg(UNETBOOTINB));
++ rootmsgb.setText(uninstaller::tr("%2 must be run as root. Close it, and re-run using either:<br/><b>sudo %1</b><br/>or:<br/><b>su -c '%1'</b>").arg(app.applicationFilePath()).arg(UNETBOOTINB));
+ rootmsgb.setStandardButtons(QMessageBox::Ok);
+ switch (rootmsgb.exec())
+ {
diff --git a/unetbootin.sh b/unetbootin.sh
index 89f840428928..c44f0b45b216 100644
--- a/unetbootin.sh
+++ b/unetbootin.sh
@@ -1,7 +1,8 @@
#!/bin/bash
-export QT_X11_NO_MITSHM=1
+#export QT_X11_NO_MITSHM=1
if [ $(which pkexec) ]; then
- pkexec --disable-internal-agent "/usr/bin/unetbootin.elf" "$@" 2>/tmp/_polkit_error
+ pkexec "/usr/bin/unetbootin.elf" "$@" 2>/tmp/_polkit_error
+ #pkexec --disable-internal-agent "/usr/bin/unetbootin.elf" "$@" 2>/tmp/_polkit_error
if [ -s /tmp/_polkit_error ]; then
zenity --error --text="`cat /tmp/_polkit_error`"
rm /tmp/_polkit_error