summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2020-06-10 01:51:54 -0600
committerBrian Bidulock2020-06-10 01:51:54 -0600
commit06693f026030ad8c7087721c5a9144a447fbd448 (patch)
treec2e9cadaa0908a8b7997188753607766644122c3
downloadaur-06693f026030ad8c7087721c5a9144a447fbd448.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9379eb68f8b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = unexicon-sound-theme
+ pkgdesc = XDG sound theme for the unexicon distribution
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bbidulock/
+ arch = any
+ groups = unexicon
+ license = GPL
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = flite
+ makedepends = flite-voices
+ makedepends = sox
+ depends = sound-theme-freedesktop
+ depends = sound-theme-smooth
+ depends = linux-a11y-sound-theme
+ source = https://github.com/bbidulock/unexicon-sound-theme/releases/download/1.0/unexicon-sound-theme-1.0.tar.lz
+ sha256sums = 0d9d3f72dd27e2da7a2cf47ddf4f100882102e0aeb55bfce16b132de4814c115
+
+pkgname = unexicon-sound-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4185b915840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgdesc="XDG sound theme for the unexicon distribution"
+pkgname=unexicon-sound-theme
+pkgver=1.0
+pkgrel=1
+arch=('any')
+license=('GPL')
+url="https://github.com/bbidulock/${_pkgname}"
+groups=('unexicon')
+depends=('sound-theme-freedesktop' 'sound-theme-smooth' 'linux-a11y-sound-theme')
+makedepends=('git' 'pkgconfig' 'flite' 'flite-voices' 'sox')
+source=("https://github.com/bbidulock/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.lz")
+sha256sums=('0d9d3f72dd27e2da7a2cf47ddf4f100882102e0aeb55bfce16b132de4814c115')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure
+ make
+}
+
+package() {
+ make -C ${pkgname}-${pkgver} DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: