summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2020-06-10 01:45:30 -0600
committerBrian Bidulock2020-06-10 01:45:30 -0600
commit33925c436bd17b5be50e337390b1c49504e33695 (patch)
treed39018878d5f787350ff905119d890ec3b7421b0
downloadaur-33925c436bd17b5be50e337390b1c49504e33695.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b702e9d1d5f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = unexicon-sound-theme-git
+ pkgdesc = XDG sound theme for the unexicon distribution
+ pkgver = 1.0.r1.g38e8a0d
+ pkgrel = 1
+ url = https://github.com/bbidulock/unexicon-sound-theme
+ arch = any
+ groups = unexicon
+ license = GPL
+ makedepends = git
+ makedepends = pkgconfig
+ makedepends = flite
+ makedepends = flite-voices
+ makedepends = sox
+ depends = sound-theme-freedesktop
+ depends = sound-theme-smooth
+ depends = linux-a11y-sound-theme
+ provides = unexicon-sound-theme=1.0-1
+ conflicts = unexicon-sound-theme
+ source = unexicon-sound-theme-git::git://github.com/bbidulock/unexicon-sound-theme.git
+ sha256sums = SKIP
+
+pkgname = unexicon-sound-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b70c8f67e8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgdesc="XDG sound theme for the unexicon distribution"
+pkgname=unexicon-sound-theme-git
+_pkgname=unexicon-sound-theme
+pkgver=1.0.r1.g38e8a0d
+pkgrel=1
+arch=('any')
+license=('GPL')
+url="https://github.com/bbidulock/${_pkgname}"
+groups=('unexicon')
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
+depends=('sound-theme-freedesktop' 'sound-theme-smooth' 'linux-a11y-sound-theme')
+makedepends=('git' 'pkgconfig' 'flite' 'flite-voices' 'sox')
+source=("$pkgname::git://github.com/bbidulock/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure
+ make
+}
+
+package() {
+ make -C ${pkgname} DESTDIR="${pkgdir}" install
+}
+