summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryoungunix2019-05-01 14:19:39 -0400
committeryoungunix2019-05-01 14:19:39 -0400
commit982a104b20523b8b1efc384d2bf60cddc66cc823 (patch)
tree64c4a86b27fb8b30ef41a3a09d3081b329df227a
downloadaur-982a104b20523b8b1efc384d2bf60cddc66cc823.tar.gz
initializing a new repo
-rw-r--r--.SRCINFO73
-rw-r--r--PKGBUILD194
2 files changed, 267 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79d355ded26f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,73 @@
+pkgbase = ungoogled-chromium
+ pkgdesc = A lightweight approach to removing Google web service dependency
+ pkgver = 74.0.3729.108
+ pkgrel = 1
+ url = https://github.com/ungoogled-software/ungoogled-chromium-archlinux
+ arch = x86_64
+ license = BSD
+ makedepends = python
+ makedepends = python2
+ makedepends = gperf
+ makedepends = yasm
+ makedepends = mesa
+ makedepends = ninja
+ makedepends = git
+ makedepends = clang
+ makedepends = lld
+ makedepends = gn
+ makedepends = llvm
+ makedepends = quilt
+ depends = gtk3
+ depends = nss
+ depends = alsa-lib
+ depends = xdg-utils
+ depends = libxss
+ depends = libcups
+ depends = libgcrypt
+ depends = ttf-font
+ depends = systemd
+ depends = dbus
+ depends = libpulse
+ depends = pciutils
+ depends = json-glib
+ depends = libva
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = jsoncpp
+ depends = openjpeg2
+ depends = icu
+ depends = libxml2
+ depends = fontconfig
+ depends = harfbuzz
+ depends = libvpx
+ depends = libjpeg
+ depends = re2
+ depends = libevent
+ depends = snappy
+ depends = ffmpeg
+ depends = flac
+ depends = libwebp
+ depends = minizip
+ depends = libxslt
+ depends = freetype2
+ depends = opus
+ optdepends = pepper-flash: support for Flash content
+ optdepends = kdialog: needed for file dialogs in KDE
+ optdepends = gnome-keyring: for storing passwords in GNOME keyring
+ optdepends = kwallet: for storing passwords in KWallet
+ optdepends = libva-intel-driver: for hardware video acceleration with Intel GPUs
+ optdepends = libva-mesa-driver: for hardware video acceleration with AMD/ATI GPUs
+ optdepends = libva-vdpau-driver: for hardware video acceleration with NVIDIA GPUs
+ provides = chromium
+ conflicts = chromium
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-74.0.3729.108.tar.xz
+ source = chromium-launcher-6.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v6.tar.gz
+ source = ungoogled-chromium-9fa9c7ad3d1191f1977efad7880e1f0fae9e792c.tar.gz::https://github.com/Eloston/ungoogled-chromium/archive/9fa9c7ad3d1191f1977efad7880e1f0fae9e792c.tar.gz
+ source = ungoogled-chromium-archlinux-5d46bb543f71d2ddcb5ced543cec89e617b6c189.tar.gz::https://github.com/ungoogled-software/ungoogled-chromium-archlinux/archive/5d46bb543f71d2ddcb5ced543cec89e617b6c189.tar.gz
+ sha256sums = 1e1e5e06fe24309377630800b44b5c6b624b7c722b5d9789abe80a962b945b6f
+ sha256sums = 04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = ungoogled-chromium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f8be43d89874
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,194 @@
+# maintainer: youngunix <zagazaw2004 [at] gmail [dot] com>
+# submitter: youngunix <zagazaw2004 [at] gmail [dot] com>
+#----------------------------------------------------------
+# Git original comments
+# Derived from PKGBUILD for Inox
+# Original Inox PKGBUILD authors:
+# Maintainer: Michael Egger <gcarq@archlinux.info>
+# Contributor: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=ungoogled-chromium
+# Commit or tag for the upstream ungoogled-chromium repo
+_ungoogled_version=9fa9c7ad3d1191f1977efad7880e1f0fae9e792c
+_ungoogled_archlinux_version=5d46bb543f71d2ddcb5ced543cec89e617b6c189
+_chromium_version=$(curl -sL https://raw.githubusercontent.com/Eloston/ungoogled-chromium/${_ungoogled_version}/chromium_version.txt)
+_ungoogled_revision=$(curl -sL https://raw.githubusercontent.com/Eloston/ungoogled-chromium/${_ungoogled_version}/revision.txt)
+pkgver=${_chromium_version}
+pkgrel=${_ungoogled_revision}
+_launcher_ver=6
+pkgdesc="A lightweight approach to removing Google web service dependency"
+arch=('x86_64')
+url="https://github.com/ungoogled-software/ungoogled-chromium-archlinux"
+license=('BSD')
+depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
+ 'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib' 'libva'
+ 'desktop-file-utils' 'hicolor-icon-theme' 'jsoncpp' 'openjpeg2')
+makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'git'
+ 'clang' 'lld' 'gn' 'llvm' 'quilt')
+optdepends=('pepper-flash: support for Flash content'
+ 'kdialog: needed for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
+ 'kwallet: for storing passwords in KWallet'
+ 'libva-intel-driver: for hardware video acceleration with Intel GPUs'
+ 'libva-mesa-driver: for hardware video acceleration with AMD/ATI GPUs'
+ 'libva-vdpau-driver: for hardware video acceleration with NVIDIA GPUs')
+provides=('chromium')
+conflicts=('chromium')
+source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-${_chromium_version}.tar.xz
+ chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
+ "ungoogled-chromium-${_ungoogled_version}.tar.gz::https://github.com/Eloston/ungoogled-chromium/archive/${_ungoogled_version}.tar.gz"
+ "ungoogled-chromium-archlinux-${_ungoogled_archlinux_version}.tar.gz::https://github.com/ungoogled-software/ungoogled-chromium-archlinux/archive/${_ungoogled_archlinux_version}.tar.gz")
+sha256sums=($(curl -sL https://commondatastorage.googleapis.com/chromium-browser-official/chromium-${_chromium_version}.tar.xz.hashes | grep sha256 | cut -d ' ' -f3)
+ '04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
+ 'SKIP'
+ 'SKIP')
+
+# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
+# Keys are the names in the above script; values are the dependencies in Arch
+declare -gA _system_libs=(
+ [ffmpeg]=ffmpeg
+ [flac]=flac
+ [fontconfig]=fontconfig
+ [freetype]=freetype2
+ [harfbuzz-ng]=harfbuzz
+ [icu]=icu
+ [libdrm]=
+ [libevent]=libevent
+ [libjpeg]=libjpeg
+ #[libpng]=libpng # https://crbug.com/752403#c10
+ [libvpx]=libvpx
+ [libwebp]=libwebp
+ [libxml]=libxml2
+ [libxslt]=libxslt
+ [opus]=opus
+ [re2]=re2
+ [snappy]=snappy
+ [yasm]=
+ [zlib]=minizip
+)
+_unwanted_bundled_libs=(
+ ${!_system_libs[@]}
+ ${_system_libs[libjpeg]+libjpeg_turbo}
+)
+depends+=(${_system_libs[@]})
+
+prepare() {
+ _ungoogled_archlinux_repo="$srcdir/$pkgname-archlinux-${_ungoogled_archlinux_version}"
+ _ungoogled_repo="$srcdir/$pkgname-${_ungoogled_version}"
+ _utils="${_ungoogled_repo}/utils"
+
+ cd "$srcdir/chromium-${_chromium_version}"
+
+ msg2 'Pruning binaries'
+ python "$_utils/prune_binaries.py" ./ "$_ungoogled_repo/pruning.list"
+ msg2 'Applying patches'
+ python "$_utils/patches.py" apply ./ "$_ungoogled_repo/patches" "$_ungoogled_archlinux_repo/patches"
+ msg2 'Applying domain substitution'
+ python "$_utils/domain_substitution.py" apply -r "$_ungoogled_repo/domain_regex.list" -f "$_ungoogled_repo/domain_substitution.list" -c domainsubcache.tar.gz ./
+
+ # Force script incompatible with Python 3 to use /usr/bin/python2
+ sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
+
+ # Remove bundled libraries for which we will use the system copies; this
+ # *should* do what the remove_bundled_libraries.py script does, with the
+ # added benefit of not having to list all the remaining libraries
+ local _lib
+ for _lib in ${_unwanted_bundled_libs[@]}; do
+ find -type f -path "*third_party/$_lib/*" \
+ \! -path "*third_party/$_lib/chromium/*" \
+ \! -path "*third_party/$_lib/google/*" \
+ \! -path './base/third_party/icu/*' \
+ \! -path './third_party/crashpad/crashpad/third_party/zlib/zlib_crashpad.h' \
+ \! -path './third_party/pdfium/third_party/freetype/include/pstables.h' \
+ \! -path './third_party/yasm/run_yasm.py' \
+ \! -regex '.*\.\(gn\|gni\|isolate\)' \
+ -delete
+ done
+
+ python2 build/linux/unbundle/replace_gn_files.py \
+ --system-libraries "${!_system_libs[@]}"
+}
+
+build() {
+ make -C chromium-launcher-$_launcher_ver
+
+ cd "$srcdir/chromium-${_chromium_version}"
+
+ if check_buildoption ccache y; then
+ # Avoid falling back to preprocessor mode when sources contain time macros
+ export CCACHE_SLOPPINESS=time_macros
+ fi
+
+ export CC=clang
+ export CXX=clang++
+ export AR=llvm-ar
+ export NM=llvm-nm
+
+ mkdir -p out/Default
+
+ # Assemble GN flags
+ cp "$_ungoogled_repo/flags.gn" "out/Default/args.gn"
+ printf '\n' >> "out/Default/args.gn"
+ cat "$_ungoogled_archlinux_repo/flags.archlinux.gn" >> "out/Default/args.gn"
+
+ # Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
+ CFLAGS+=' -Wno-builtin-macro-redefined'
+ CXXFLAGS+=' -Wno-builtin-macro-redefined'
+ CPPFLAGS+=' -D__DATE__= -D__TIME__= -D__TIMESTAMP__='
+
+ msg2 'Configuring Chromium'
+ gn gen out/Default --script-executable=/usr/bin/python2 --fail-on-unused-args
+ msg2 'Building Chromium'
+ ninja -C out/Default chrome chrome_sandbox chromedriver
+}
+
+package() {
+ cd chromium-launcher-$_launcher_ver
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
+
+ cd "$srcdir/chromium-${_chromium_version}"
+
+ install -D out/Default/chrome "$pkgdir/usr/lib/chromium/chromium"
+ install -Dm4755 out/Default/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
+ ln -s /usr/lib/$pkgname/chromedriver "$pkgdir/usr/bin/chromedriver"
+
+ install -Dm644 chrome/installer/linux/common/desktop.template \
+ "$pkgdir/usr/share/applications/chromium.desktop"
+ install -Dm644 chrome/app/resources/manpage.1.in \
+ "$pkgdir/usr/share/man/man1/chromium.1"
+ sed -i \
+ -e "s/@@MENUNAME@@/Chromium/g" \
+ -e "s/@@PACKAGE@@/chromium/g" \
+ -e "s/@@USR_BIN_SYMLINK_NAME@@/chromium/g" \
+ "$pkgdir/usr/share/applications/chromium.desktop" \
+ "$pkgdir/usr/share/man/man1/chromium.1"
+
+ cp \
+ out/Default/{chrome_{100,200}_percent,resources}.pak \
+ out/Default/{*.bin,chromedriver} \
+ "$pkgdir/usr/lib/chromium/"
+ install -Dm644 -t "$pkgdir/usr/lib/chromium/locales" out/Default/locales/*.pak
+
+ if [[ -z ${_system_libs[icu]+set} ]]; then
+ cp out/Default/icudtl.dat "$pkgdir/usr/lib/chromium/"
+ fi
+
+ for size in 22 24 48 64 128 256; do
+ install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ for size in 16 32; do
+ install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: