summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2024-05-15 15:34:40 +0200
committerNoah Vogt2024-05-15 15:34:40 +0200
commit566abe59fb626f238540e56f9907c7702e2eb955 (patch)
tree65af0a6273813d102659d3776b237f7fd6b56ab8
parent77c047c2af5ef7c35f2dafe1b65c5f28a8f409d9 (diff)
downloadaur-566abe59fb626f238540e56f9907c7702e2eb955.tar.gz
add ninja fix + change a flag
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--ninja-out-of-order-generation-fix.patch38
3 files changed, 47 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b4709c0b22d..1b274fc2a900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -73,6 +73,7 @@ pkgbase = ungoogled-chromium-xdg
source = 0001-enable-linux-unstable-deb-target.patch
source = 0001-ozone-wayland-implement-text_input_manager_v3.patch
source = 0001-ozone-wayland-implement-text_input_manager-fixes.patch
+ source = ninja-out-of-order-generation-fix.patch
sha256sums = 05652bf7a89c637f99cfc02cc9d312da074d2d0bce34d311434de3d36543dc72
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = 58c8787bd215c4818893405dbb88c17b08bf13039fb5fbcb9dfe95ac51a86f3e
@@ -88,5 +89,6 @@ pkgbase = ungoogled-chromium-xdg
sha256sums = 2a44756404e13c97d000cc0d859604d6848163998ea2f838b3b9bb2c840967e3
sha256sums = d9974ddb50777be428fd0fa1e01ffe4b587065ba6adefea33678e1b3e25d1285
sha256sums = a2da75d0c20529f2d635050e0662941c0820264ea9371eb900b9d90b5968fa6a
+ sha256sums = 813e6a1209ab72e4ab34f5f062412087e9664189d7b8f1dc1d0bb9481c574c45
pkgname = ungoogled-chromium-xdg
diff --git a/PKGBUILD b/PKGBUILD
index 0906d486e74b..e8104b9c6d17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -75,13 +75,15 @@ source=(${source[@]}
0001-adjust-buffer-format-order.patch
0001-enable-linux-unstable-deb-target.patch
0001-ozone-wayland-implement-text_input_manager_v3.patch
- 0001-ozone-wayland-implement-text_input_manager-fixes.patch)
+ 0001-ozone-wayland-implement-text_input_manager-fixes.patch
+ ninja-out-of-order-generation-fix.patch)
sha256sums=(${sha256sums[@]}
'8f4ae7ed5e3a9e9322dd57285ea00866ce535260cb8045773a2121e239c746f4'
'8ba5c67b7eb6cacd2dbbc29e6766169f0fca3bbb07779b1a0a76c913f17d343f'
'2a44756404e13c97d000cc0d859604d6848163998ea2f838b3b9bb2c840967e3'
'd9974ddb50777be428fd0fa1e01ffe4b587065ba6adefea33678e1b3e25d1285'
- 'a2da75d0c20529f2d635050e0662941c0820264ea9371eb900b9d90b5968fa6a')
+ 'a2da75d0c20529f2d635050e0662941c0820264ea9371eb900b9d90b5968fa6a'
+ '813e6a1209ab72e4ab34f5f062412087e9664189d7b8f1dc1d0bb9481c574c45')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -153,6 +155,9 @@ prepare() {
# Allow libclang_rt.builtins from compiler-rt >= 16 to be used
patch -Np1 -i ../compiler-rt-adjust-paths.patch
+ # Fix ninja 1.12 generating files out of order
+ patch -Np1 -i ../ninja-out-of-order-generation-fix.patch
+
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch
@@ -247,7 +252,6 @@ build() {
'use_custom_libcxx=true' # https://github.com/llvm/llvm-project/issues/61705
'use_sysroot=false'
'use_system_libffi=true'
- 'enable_hangout_services_extension=true'
'enable_widevine=true'
'enable_nacl=false'
'use_qt6=true'
diff --git a/ninja-out-of-order-generation-fix.patch b/ninja-out-of-order-generation-fix.patch
new file mode 100644
index 000000000000..7b7df008f086
--- /dev/null
+++ b/ninja-out-of-order-generation-fix.patch
@@ -0,0 +1,38 @@
+--- a/content/browser/BUILD.gn
++++ b/content/browser/BUILD.gn
+@@ -73,6 +73,7 @@
+ "//cc/animation",
+ "//cc/mojo_embedder",
+ "//cc/paint",
++ "//chrome/common:buildflags",
+ "//components/attribution_reporting:mojom",
+ "//components/back_forward_cache:enum",
+ "//components/browsing_topics/common:common",
+@@ -83,6 +84,7 @@
+ "//components/download/public/common:public",
+ "//components/file_access",
+ "//components/filename_generation",
++ "//components/lens:buildflags",
+ "//components/link_header_util",
+ "//components/metrics",
+ "//components/metrics:single_sample_metrics",
+--- a/chrome/browser/extensions/BUILD.gn
++++ b/chrome/browser/extensions/BUILD.gn
+@@ -898,6 +898,7 @@
+ "//components/resources",
+ "//components/safe_browsing:buildflags",
+ "//components/safe_browsing/content/browser/web_ui:web_ui",
++ "//components/safe_browsing/content/common/proto:download_file_types_proto",
+ "//components/safe_browsing/core/browser/db:database_manager",
+ "//components/safe_browsing/core/common",
+ "//components/safe_browsing/core/common:safe_browsing_prefs",
+--- a/chrome/common/BUILD.gn
++++ b/chrome/common/BUILD.gn
+@@ -605,6 +605,7 @@
+ "//components/optimization_guide/optimization_guide_internals/webui:url_constants",
+ "//components/password_manager/content/common",
+ "//components/safe_browsing/core/common",
++ "//components/supervised_user/core/common:buildflags",
+ "//device/vr/buildflags",
+ ]
+ }