summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2024-01-27 21:57:28 +0100
committerNoah Vogt2024-01-27 21:57:28 +0100
commit7655cec319429bbf298494e03fb8da9d584bff14 (patch)
treebb63d6330e062c743c17b4815cc1b57a4aa98039
parent77b8fc20d102f546bf303806bd0a3618f76dc531 (diff)
downloadaur-7655cec319429bbf298494e03fb8da9d584bff14.tar.gz
move ungoogled chromium changes
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 654ec300b61f..ed85d9af0c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -182,17 +182,6 @@ prepare() {
# called 'shoulder surfing').
patch -p1 -i ../no-omnibox-suggestion-autocomplete.patch
- # Ungoogled Chromium changes
- _ungoogled_repo="$srcdir/${pkgname%xdg*}$_uc_ver"
-
- _utils="${_ungoogled_repo}/utils"
- msg2 'Pruning binaries'
- python "$_utils/prune_binaries.py" ./ "$_ungoogled_repo/pruning.list"
- msg2 'Applying patches'
- python "$_utils/patches.py" apply ./ "$_ungoogled_repo/patches"
- msg2 'Applying domain substitution'
- python "$_utils/domain_substitution.py" apply -r "$_ungoogled_repo/domain_regex.list" \
- -f "$_ungoogled_repo/domain_substitution.list" -c domainsubcache.tar.gz ./
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
@@ -206,6 +195,17 @@ prepare() {
# To link to rust libraries we need to compile with prebuilt clang
./tools/clang/scripts/update.py
+ # Ungoogled Chromium changes
+ _ungoogled_repo="$srcdir/${pkgname%xdg*}$_uc_ver"
+
+ _utils="${_ungoogled_repo}/utils"
+ msg2 'Pruning binaries'
+ python "$_utils/prune_binaries.py" ./ "$_ungoogled_repo/pruning.list"
+ msg2 'Applying patches'
+ python "$_utils/patches.py" apply ./ "$_ungoogled_repo/patches"
+ msg2 'Applying domain substitution'
+ python "$_utils/domain_substitution.py" apply -r "$_ungoogled_repo/domain_regex.list" \
+ -f "$_ungoogled_repo/domain_substitution.list" -c domainsubcache.tar.gz ./
# Remove bundled libraries for which we will use the system copies; this
# *should* do what the remove_bundled_libraries.py script does, with the