summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2024-02-16 19:03:16 +0100
committerNoah Vogt2024-02-16 19:03:16 +0100
commite08cff6441119fcbe638e0096eb85b5e04e8371e (patch)
tree24ec76ba955c4c80f4015b0b35984ad846277bcc
parent840840556f731443a0a2e544fb4696d0ba56183b (diff)
downloadaur-e08cff6441119fcbe638e0096eb85b5e04e8371e.tar.gz
add rust flags
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e83ceaae96de..6f1185524a31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -300,7 +300,16 @@ build() {
'clang_base_path="/usr"'
'clang_use_chrome_plugins=false'
"clang_version=\"$_clang_version\""
- #'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
+ 'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
+ )
+
+ # Allow the use of nightly features with stable Rust compiler
+ # https://github.com/ungoogled-software/ungoogled-chromium/pull/2696#issuecomment-1918173198
+ export RUSTC_BOOTSTRAP=1
+
+ _flags+=(
+ 'rust_sysroot_absolute="/usr"'
+ "rustc_version=\"$(rustc --version)\""
)
fi