summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2022-12-19 18:45:00 +0100
committerNoah Vogt2022-12-19 18:45:00 +0100
commite5d928ea08a776425f34dcde729879965e2ac79c (patch)
tree5a562dcbe7fdfef8d452c8c7a501ba64c9bde0b3
parent65cb555c3f82cc18df7c0254f39eb5c169300a2a (diff)
downloadaur-e5d928ea08a776425f34dcde729879965e2ac79c.tar.gz
uppkg -> 108.0.5359.124-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c46c6dde92bd..3846033b0308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ungoogled-chromium-xdg
pkgdesc = A lightweight approach to removing Google web service dependency - without creating a useless ~/.pki directory
- pkgver = 108.0.5359.98
+ pkgver = 108.0.5359.124
pkgrel = 1
url = https://github.com/ungoogled-software/ungoogled-chromium
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = ungoogled-chromium-xdg
makedepends = gperf
makedepends = nodejs
makedepends = pipewire
+ makedepends = qt5-base
makedepends = java-runtime-headless
makedepends = git
depends = gtk3
@@ -54,13 +55,14 @@ pkgbase = ungoogled-chromium-xdg
depends = freetype2
optdepends = pipewire: WebRTC desktop sharing under Wayland
optdepends = kdialog: support for native dialogs in Plasma
+ optdepends = qt5-base: enable Qt5 with --enable-features=AllowQt
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
optdepends = kwallet: support for storing passwords in KWallet on Plasma
provides = chromium
conflicts = chromium
options = debug
options = !lto
- source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-108.0.5359.98.tar.xz
+ source = https://commondatastorage.googleapis.com/chromium-browser-official/chromium-108.0.5359.124.tar.xz
source = https://github.com/foutrelis/chromium-launcher/archive/v8/chromium-launcher-8.tar.gz
source = https://github.com/stha09/chromium-patches/releases/download/chromium-108-patchset-2/chromium-108-patchset-2.tar.xz
source = re-fix-TFLite-build-error-on-linux-with-system-zlib.patch
@@ -74,11 +76,11 @@ pkgbase = ungoogled-chromium-xdg
source = xdg-basedir.patch
source = no-omnibox-suggestion-autocomplete.patch
source = index.html
- source = ungoogled-chromium-108.0.5359.98-1.tar.gz::https://github.com/ungoogled-software/ungoogled-chromium/archive/108.0.5359.98-1.tar.gz
+ source = ungoogled-chromium-108.0.5359.124-1.tar.gz::https://github.com/ungoogled-software/ungoogled-chromium/archive/108.0.5359.124-1.tar.gz
source = ozone-add-va-api-support-to-wayland.patch
source = remove-main-main10-profile-limit.patch
source = chromium-drirc-disable-10bpc-color-configs.conf
- sha256sums = 60b6137971e3cb2947477f654491ed4f517ab88ea2807fa3b89fcce34b83561e
+ sha256sums = d48dfac2a61b14a5d7d2f460b09b70ef3ab88e27b82e3173938cb54eaa612a75
sha256sums = 213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a
sha256sums = 40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652
sha256sums = 9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716
@@ -92,7 +94,7 @@ pkgbase = ungoogled-chromium-xdg
sha256sums = cd844867b5b2197ad097662fee32579a7091dfba1d46cb438c4c7e696690440a
sha256sums = ff1591fa38e0ede7e883dc7494b813641b7a1a7cb1ded00d9baaee987c1dbea8
sha256sums = a4cdd2b86f32d5302c2792be841ff40d982b19bb58a4e63df9d77f4c706b8665
- sha256sums = 91afcb2ab483b226979b4114ba5ce2aa462658688c10cafd29f78c4be607357e
+ sha256sums = ac71aa130e70bcb5b30fc5f899239851b4bff05938cf4fe6d3f8c2da04e85f70
sha256sums = e9e8d3a82da818f0a67d4a09be4ecff5680b0534d7f0198befb3654e9fab5b69
sha256sums = fc810e3c495c77ac60b383a27e48cf6a38b4a95b65dd2984baa297c5df83133c
sha256sums = babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb
diff --git a/PKGBUILD b/PKGBUILD
index 8bd7e761d816..dd4821de09d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium-xdg
-pkgver=108.0.5359.98
+pkgver=108.0.5359.124
pkgrel=1
_launcher_ver=8
_gcc_patchset=2
@@ -22,9 +22,10 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'wayland' 'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'git')
+ 'qt5-base' 'java-runtime-headless' 'git')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
+ 'qt5-base: enable Qt5 with --enable-features=AllowQt'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
@@ -42,7 +43,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
xdg-basedir.patch
no-omnibox-suggestion-autocomplete.patch
index.html)
-sha256sums=('60b6137971e3cb2947477f654491ed4f517ab88ea2807fa3b89fcce34b83561e'
+sha256sums=('d48dfac2a61b14a5d7d2f460b09b70ef3ab88e27b82e3173938cb54eaa612a75'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'40ef8af65e78901bb8554eddbbb5ebc55c0b8e7927f6ca51b2a353d1c7c50652'
'9015b9d6d5b4c1e7248d6477a4b4b6bd6a3ebdc57225d2d8efcd79fc61790716'
@@ -66,7 +67,7 @@ source=(${source[@]}
remove-main-main10-profile-limit.patch
chromium-drirc-disable-10bpc-color-configs.conf)
sha256sums=(${sha256sums[@]}
- '91afcb2ab483b226979b4114ba5ce2aa462658688c10cafd29f78c4be607357e'
+ 'ac71aa130e70bcb5b30fc5f899239851b4bff05938cf4fe6d3f8c2da04e85f70'
'e9e8d3a82da818f0a67d4a09be4ecff5680b0534d7f0198befb3654e9fab5b69'
'fc810e3c495c77ac60b383a27e48cf6a38b4a95b65dd2984baa297c5df83133c'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb')
@@ -209,7 +210,6 @@ build() {
'link_pulseaudio=true'
'use_custom_libcxx=false'
'use_gnome_keyring=false'
- 'use_qt=false' # look into enabling this for M108
'use_sysroot=false'
'use_system_libwayland=true'
'use_system_wayland_scanner=true'
@@ -298,6 +298,7 @@ package() {
chrome_200_percent.pak
chrome_crashpad_handler
resources.pak
+ libqt5_shim.so
v8_context_snapshot.bin
# ANGLE