summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjk2021-05-02 11:56:02 -0500
committerjk2021-05-02 11:56:02 -0500
commitf575b0df983591fe422ae10f113034ced3deb280 (patch)
tree45b97b8ff3c4a1dde4e524c9b5f61b39510e9614
parent7c481ea1b3d72aed2d13ec8dc9fbc453083bfc02 (diff)
downloadaur-f575b0df983591fe422ae10f113034ced3deb280.tar.gz
upgpkg: ungoogled-chromium 90.0.4430.93-2
remove compiler flag
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04aed1f78588..5a2f00f4ab7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'libva'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'gn' 'ninja' 'clang' 'lld' 'gperf' 'nodejs' 'pipewire'
- 'java-runtime-headless' 'python2' 'python2-setuptools' 'flatbuffers')
+ 'java-runtime-headless' 'python2' 'python2-setuptools')
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: needed for file dialogs in KDE'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
@@ -139,9 +139,6 @@ prepare() {
-delete
done
- # delete flatbuffers
- rm -r third_party/flatbuffers
-
./build/linux/unbundle/replace_gn_files.py \
--system-libraries "${!_system_libs[@]}"
}
@@ -156,6 +153,8 @@ build() {
export CCACHE_SLOPPINESS=time_macros
fi
+ export CFLAGS=$(printf '%s\n' "${CFLAGS//-fcf-protection/}")
+
export CC=clang
export CXX=clang++
export AR=ar