summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah Vogt2022-04-20 00:37:53 +0200
committerNoah Vogt2022-04-20 00:37:53 +0200
commit7d650e79e33b43ed31e717542d84a7fae412530d (patch)
tree689e1eb8d153d6e82160b7a0b2152047b4b89185
parent275bf9a1f181d02673755999d67ac1fa72b4972e (diff)
downloadaur-7d650e79e33b.tar.gz
add missing dependencies, bump -> 100.0.4896.127-2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53a54d4ab039..6692f48a2041 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ungoogled-chromium-xdg-bin
pkgdesc = A lightweight approach to removing Google web service dependency - without creating a useless ~/.pki directory (binary version)
pkgver = 100.0.4896.127
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Eloston/ungoogled-chromium
arch = x86_64
license = BSD
@@ -20,6 +20,21 @@ pkgbase = ungoogled-chromium-xdg-bin
depends = libva
depends = desktop-file-utils
depends = hicolor-icon-theme
+ depends = fontconfig
+ depends = libjpeg
+ depends = icu
+ depends = flac
+ depends = snappy
+ depends = libxml2
+ depends = ffmpeg
+ depends = libwebp
+ depends = minizip
+ depends = opus
+ depends = harfbuzz
+ depends = re2
+ depends = libxslt
+ depends = libpng
+ depends = freetype2
optdepends = pipewire: WebRTC desktop sharing under Wayland
optdepends = kdialog: support for native dialogs in Plasma
optdepends = org.freedesktop.secrets: password storage backend on GNOME / Xfce
@@ -27,7 +42,7 @@ pkgbase = ungoogled-chromium-xdg-bin
provides = chromium
conflicts = chromium
options = !lto
- source = https://github.com/noahvogt/ungoogled-chromium-xdg-aur/releases/download/100.0.4896.127-1/ungoogled-chromium-xdg-bin-100.0.4896.127.tar.gz
+ source = https://github.com/noahvogt/ungoogled-chromium-xdg-aur/releases/download/100.0.4896.127-2/ungoogled-chromium-xdg-bin-100.0.4896.127.tar.gz
source = index.html
sha256sums = 96982ce7c44b3ceae4eb4778d89f192c722c6887dba2de3bb1bec4cc2ae3ebbf
sha256sums = a4cdd2b86f32d5302c2792be841ff40d982b19bb58a4e63df9d77f4c706b8665
diff --git a/PKGBUILD b/PKGBUILD
index 193c264f669f..d7c5d4a9b6cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=ungoogled-chromium-xdg-bin
pkgver=100.0.4896.127
-pkgrel=1
+pkgrel=2
_launcher_ver=8
pkgdesc="A lightweight approach to removing Google web service dependency - without creating a useless ~/.pki directory (binary version)"
arch=('x86_64')
@@ -32,6 +32,32 @@ sha256sums=('96982ce7c44b3ceae4eb4778d89f192c722c6887dba2de3bb1bec4cc2ae3ebbf'
provides=('chromium')
conflicts=('chromium')
+# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
+# Keys are the names in the above script; values are the dependencies in Arch
+declare -gA _system_libs=(
+ [ffmpeg]=ffmpeg
+ [flac]=flac
+ [fontconfig]=fontconfig
+ [freetype]=freetype2
+ [harfbuzz-ng]=harfbuzz
+ [icu]=icu
+ [libdrm]=
+ [libjpeg]=libjpeg
+ [libpng]=libpng
+ #[libvpx]=libvpx
+ [libwebp]=libwebp
+ [libxml]=libxml2
+ [libxslt]=libxslt
+ [opus]=opus
+ [re2]=re2
+ [snappy]=snappy
+ [zlib]=minizip
+)
+_unwanted_bundled_libs=(
+ $(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')
+)
+depends+=(${_system_libs[@]})
+
package() {
cd "$pkgname/chromium-launcher-$_launcher_ver"
make PREFIX=/usr DESTDIR="$pkgdir" install