summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2015-07-03 14:01:21 +0200
committerPhilipp A2015-07-03 14:02:39 +0200
commit16bff54d5cc95e7c38de253b41469c136ec8b49c (patch)
tree1ec07c06159492440e1d9bf90fb741f30e5507a4
parentcea5e3b90f5bd7f1b5ff0cf564d6479141e01034 (diff)
downloadaur-16bff54d5cc95e7c38de253b41469c136ec8b49c.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitmodules0
-rw-r--r--PKGBUILD35
3 files changed, 26 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82c2f0ddd55b..29159e523e6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = unicodemoticon
- pkgdesc = Tray icon with Unicode Emoticons using Python3 Qt5
- pkgver = 1.0.2
+ pkgdesc = Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5.
+ pkgver = 1.0.6
pkgrel = 1
url = https://github.com/juancarlospaco/unicodemoticon
arch = any
- license = Apache
+ license = GPL
makedepends = python-distribute
depends = python
depends = python-pyqt5
optdepends = ttf-symbola: Font with emoji
- source = https://pypi.python.org/packages/source/u/unicodemoticon/unicodemoticon-1.0.2.tar.gz
- md5sums = 0069de8fa1300d5cc1e7aeee713f316f
+ source = https://pypi.python.org/packages/source/u/unicodemoticon/unicodemoticon-1.0.6.zip
+ md5sums = 781f8af6d1b07e8a97c29aaacb8514ce
pkgname = unicodemoticon
diff --git a/.gitmodules b/.gitmodules
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/.gitmodules
diff --git a/PKGBUILD b/PKGBUILD
index 9db29b507868..cba35cb001fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
+#Automatically generated by pip2arch on 2015-06-27
+
pkgname=unicodemoticon
-pkgver=1.0.2
+pkgver=1.0.6
pkgrel=1
-pkgdesc='Tray icon with Unicode Emoticons using Python3 Qt5 '
-url='https://github.com/juancarlospaco/unicodemoticon'
-arch=('any')
-license=('Apache')
+pkgdesc="Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5."
+url="https://github.com/juancarlospaco/unicodemoticon"
depends=('python' 'python-pyqt5')
optdepends=('ttf-symbola: Font with emoji')
makedepends=('python-distribute')
-source=("https://pypi.python.org/packages/source/u/$pkgname/$pkgname-$pkgver.tar.gz")
-md5sums=('0069de8fa1300d5cc1e7aeee713f316f')
+license=('GPL')
+arch=('any')
+source=("https://pypi.python.org/packages/source/u/$pkgname/$pkgname-$pkgver.zip")
+md5sums=('781f8af6d1b07e8a97c29aaacb8514ce')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+
+ python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
-
- install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
- install -Dm755 unicodemoticon.py "$pkgdir/usr/bin/unicodemoticon.py"
-} \ No newline at end of file
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
+}