summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2016-08-09 09:25:29 +0200
committerPhilipp A2016-08-09 09:25:29 +0200
commitacf57b162cbe60475e8ecb190d396cc92a814972 (patch)
treeb3887c7ff5f3c21986c40e35ff1500264fde3387
parent19bbf85e8c69174881d8e3facdda1557874576bd (diff)
downloadaur-acf57b162cbe60475e8ecb190d396cc92a814972.tar.gz
bumped to version 2.3.4
-rw-r--r--PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65fbc58b772f..cce12e41f0c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,22 @@
pkgname=unicodemoticon
-pkgver=2.1.1
-pkgrel=4
+pkgver=2.3.4
+pkgrel=1
pkgdesc="Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5."
url="https://github.com/juancarlospaco/unicodemoticon"
-depends=('python' 'python-pyqt5')
-optdepends=(
- 'ttf-symbola: Font with emoji'
- 'noto-fonts-emoji: Another font with emoji'
- 'noto-fonts: Fonts designed to cover a wide unicode range'
- 'ttf-freefont: Another font covering a wide unicode range'
- 'ttf-ancient-fonts: Contains ttf-symbola and yet more fonts covering a wide unicode range'
-)
+depends=('python' 'python-pyqt5' 'python-anglerfish')
+optdepends=('ttf-symbola: Font with emoji')
makedepends=('python-distribute')
license=('GPL')
arch=('any')
-source=("https://github.com/juancarlospaco/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('625d87e9d73fa1a72b3b029d80f56a63e72b4d56f7bdfebf02ed05f1aa0fef52')
+source=("https://files.pythonhosted.org/packages/source/u/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('97caf0797231077eec7bbb8c58957a63')
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
+
+ python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
}
@@ -28,5 +24,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm755 unicodemoticon/unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
+ install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
}