summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2016-08-09 09:33:47 +0200
committerPhilipp A2016-08-09 09:33:47 +0200
commitc3e4ad5668a3a40a480c513bba53aa00d9d5210c (patch)
tree32f94e52772d6e610474152f0b0fc25d3facdfb2
parentacf57b162cbe60475e8ecb190d396cc92a814972 (diff)
downloadaur-c3e4ad5668a3a40a480c513bba53aa00d9d5210c.tar.gz
re-added optionals
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f724e37f675..329c671cef6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = unicodemoticon
pkgdesc = Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5.
- pkgver = 2.1.1
- pkgrel = 4
+ pkgver = 2.3.4
+ pkgrel = 2
url = https://github.com/juancarlospaco/unicodemoticon
arch = any
license = GPL
makedepends = python-distribute
depends = python
depends = python-pyqt5
+ depends = python-anglerfish
optdepends = ttf-symbola: Font with emoji
optdepends = noto-fonts-emoji: Another font with emoji
optdepends = noto-fonts: Fonts designed to cover a wide unicode range
optdepends = ttf-freefont: Another font covering a wide unicode range
optdepends = ttf-ancient-fonts: Contains ttf-symbola and yet more fonts covering a wide unicode range
- source = https://github.com/juancarlospaco/unicodemoticon/archive/2.1.1.tar.gz
- sha256sums = 625d87e9d73fa1a72b3b029d80f56a63e72b4d56f7bdfebf02ed05f1aa0fef52
+ source = https://files.pythonhosted.org/packages/source/u/unicodemoticon/unicodemoticon-2.3.4.tar.gz
+ md5sums = 97caf0797231077eec7bbb8c58957a63
pkgname = unicodemoticon
diff --git a/PKGBUILD b/PKGBUILD
index cce12e41f0c6..d847fb5576c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,16 @@
pkgname=unicodemoticon
pkgver=2.3.4
-pkgrel=1
+pkgrel=2
pkgdesc="Like a Color Picker but for Unicode Emoticons. Trayicon with Unicode Emoticons using Python3 Qt5."
url="https://github.com/juancarlospaco/unicodemoticon"
depends=('python' 'python-pyqt5' 'python-anglerfish')
-optdepends=('ttf-symbola: Font with emoji')
+optdepends=(
+ 'ttf-symbola: Font with emoji'
+ 'noto-fonts-emoji: Another font with emoji'
+ 'noto-fonts: Fonts designed to cover a wide unicode range'
+ 'ttf-freefont: Another font covering a wide unicode range'
+ 'ttf-ancient-fonts: Contains ttf-symbola and yet more fonts covering a wide unicode range'
+)
makedepends=('python-distribute')
license=('GPL')
arch=('any')
@@ -15,8 +21,6 @@ md5sums=('97caf0797231077eec7bbb8c58957a63')
build() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py build
-
- python -c 'import unicodemoticon; print(unicodemoticon.AUTOSTART_DESKTOP_FILE)' > unicodemoticon.desktop
}
@@ -24,5 +28,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
- install -Dm755 unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
+ install -Dm755 unicodemoticon/unicodemoticon.desktop "$pkgdir/usr/share/applications/unicodemoticon.desktop"
}