summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKim Scarborough2022-01-02 08:31:15 -0600
committerKim Scarborough2022-01-02 08:31:15 -0600
commitcf58061a5850cbba4b2e5a5546caccd495e94a1d (patch)
tree802e5735535038ac144da5eac231aa6b205c327d
downloadaur-cf58061a5850cbba4b2e5a5546caccd495e94a1d.tar.gz
Initial import of unicorn-cal
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c25bc2a5f7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = unicorn-cal
+ pkgdesc = Enhanced CLI calendar
+ pkgver = 4.1
+ pkgrel = 1
+ url = http://unicorn.us.com/cal.html
+ arch = x86_64
+ arch = aarch64
+ license = custom:public domain
+ makedepends = unzip
+ source = http://unicorn.us.com/pub/cal41.zip
+ sha256sums = 96318b738970237832e4594cb363058f4243f54e86a5f1e06737fb5d02e6c298
+
+pkgname = unicorn-cal
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..226b9b75b739
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Kim Scarborough <sluggo@unknown.nu>
+
+pkgname=unicorn-cal
+pkgver=4.1
+pkgrel=1
+pkgdesc="Enhanced CLI calendar"
+arch=('x86_64' 'aarch64')
+url="http://unicorn.us.com/cal.html";
+license=('custom:public domain')
+source=("http://unicorn.us.com/pub/cal41.zip")
+sha256sums=('96318b738970237832e4594cb363058f4243f54e86a5f1e06737fb5d02e6c298')
+makedepends=('unzip')
+
+build() {
+ cd "cal41/src"
+ make -f makefile.unx
+}
+
+package() {
+ cd "cal41/src"
+ mv cal unicorn-cal
+ mv cal.1 unicorn-cal.1
+ install -D -s -t ${pkgdir}/usr/bin/ unicorn-cal
+ install -D -m 0644 -t ${pkgdir}/usr/share/man/man1/ unicorn-cal.1
+}