summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAvery2022-11-17 01:26:54 +0800
committerAvery2022-11-17 01:27:50 +0800
commitf27d83648c08264906068e948b40733694111088 (patch)
tree19d3bf47cf11d5e54cbdc7e759589bac1e17a6a2
parentecf379f9ba555cf94d9404181e3724e89c0bf8f2 (diff)
downloadaur-unicorn-git.tar.gz
fix: fix build and remove rm of missing files
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9109a189fa36..f08313d7a8ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unicorn-git
pkgdesc = Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
- pkgver = 2.0.0.r50.g2a3cc7a1
+ pkgver = 2.0.1.r4.ge9c1c17f
pkgrel = 1
url = http://www.unicorn-engine.org
arch = i686
@@ -12,7 +12,7 @@ pkgbase = unicorn-git
makedepends = python
makedepends = python-setuptools
makedepends = ruby
- provides = unicorn=2.0.0.r50.g2a3cc7a1
+ provides = unicorn=2.0.1.r4.ge9c1c17f
conflicts = unicorn
options = !emptydirs
options = debug
@@ -22,19 +22,19 @@ pkgbase = unicorn-git
pkgname = unicorn-git
depends = glibc
provides = unicorn
- provides = libunicorn.so
+ provides = libunicorn.so=2
pkgname = python-unicorn-git
depends = python
depends = unicorn
depends = python-setuptools
- provides = python-unicorn=2.0.0.r50.g2a3cc7a1
+ provides = python-unicorn=2.0.1.r4.ge9c1c17f
conflicts = python-unicorn
pkgname = ruby-unicorn-engine-git
depends = ruby
depends = unicorn
- provides = ruby-unicorn-engine=2.0.0.r50.g2a3cc7a1
+ provides = ruby-unicorn-engine=2.0.1.r4.ge9c1c17f
conflicts = ruby-unicorn-engine
replaces = ruby-unicorn
replaces = ruby-unicorn-git
diff --git a/PKGBUILD b/PKGBUILD
index ee5669014c91..18b0de18bd53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: nullableVoidPtr <nullableVoidPtr _ gmail _ com>
+# Maintainer: nullableVoidPtr <them+arch _ nullablevo _ id _ au>
# Contributor: Alex Sarum <rum.274.4 at gmail dot com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgbase=unicorn-git
pkgname=('unicorn-git' 'python-unicorn-git' 'ruby-unicorn-engine-git')
-pkgver=2.0.0.r50.g2a3cc7a1
+pkgver=2.0.1.r4.ge9c1c17f
pkgrel=1
pkgdesc='Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU'
url='http://www.unicorn-engine.org'
@@ -39,7 +39,7 @@ build() {
python const_generator.py ruby
)
(cd bindings/python
- LIBUNICORN_PATH="../../build" python setup.py build
+ env LIBUNICORN_PATH="set to not rebuild so" python setup.py build
)
(cd bindings/ruby/unicorn_gem
gem build unicorn-engine.gemspec
@@ -53,7 +53,7 @@ check() {
package_unicorn-git() {
depends=('glibc')
- provides=('unicorn' 'libunicorn.so')
+ provides=('unicorn' 'libunicorn.so=2')
cd ${pkgbase}
DESTDIR="${pkgdir}" cmake --install build
install -Dm 644 samples/*.c -t "${pkgdir}/usr/share/doc/${pkgname}/samples"
@@ -65,7 +65,6 @@ package_python-unicorn-git() {
conflicts=(python-unicorn)
cd ${pkgbase}/bindings/python
python setup.py install --root="${pkgdir}" -O1 --skip-build
- rm -r "${pkgdir}/usr/lib/"python*/site-packages/unicorn/{include,lib}
install -Dm 644 sample* shellcode.py -t "${pkgdir}/usr/share/doc/${pkgname}/samples"
}