summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaruman92019-10-29 17:54:38 +0300
committersaruman92019-10-29 17:54:38 +0300
commit2178fb312f6ca7d0764c9860f3b5055492b0d212 (patch)
tree18553e8c430c09a38f55ae70896a09e0e9b32b77
parent2567289fc7f0cec037663522d77e6347b3aa8083 (diff)
downloadaur-2178fb312f6ca7d0764c9860f3b5055492b0d212.tar.gz
Update version, change maintainer, delete checkdepends
Fix ruby package.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
-rw-r--r--fix-soname-ld-library-path.patch53
3 files changed, 7 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 446297a0518e..c08896cb3661 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = unicorn-git
pkgdesc = Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
- pkgver = 1.0.1616.15b99f1
+ pkgver = 1.0.2.rc1.r5.g3b17db0d
pkgrel = 1
url = http://www.unicorn-engine.org
arch = i686
arch = x86_64
license = GPL2
- checkdepends = cmocka
makedepends = git
makedepends = python
makedepends = python2
diff --git a/PKGBUILD b/PKGBUILD
index a9db6c4b97d3..560cbac1c0ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Maintainer: Alex Sarum <rum.274.4 at gmail dot com>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgbase=unicorn-git
pkgname=('unicorn-git' 'python-unicorn-git' 'python2-unicorn-git' 'ruby-unicorn-git')
-pkgver=1.0.1616.15b99f1
+pkgver=1.0.2.rc1.r5.g3b17db0d
pkgrel=1
pkgdesc='Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU'
url='http://www.unicorn-engine.org'
arch=('i686' 'x86_64')
license=('GPL2')
makedepends=('git' 'python' 'python2' 'python-setuptools' 'python2-setuptools' 'ruby')
-checkdepends=('cmocka')
options=('staticlibs' '!emptydirs')
source=(${pkgbase}::git+https://github.com/unicorn-engine/unicorn)
sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" \
- "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -43,13 +42,14 @@ build() {
python2 setup.py build
)
(cd bindings/ruby/unicorn_gem
- gem build unicorn.gemspec
+ gem build unicorn-engine.gemspec
)
}
check() {
cd ${pkgbase}
# Tests are not supported right now, hope they get some love soon
+ # checkdepends=('cmocka')
# make test
}
diff --git a/fix-soname-ld-library-path.patch b/fix-soname-ld-library-path.patch
deleted file mode 100644
index e4d0ac310ee8..000000000000
--- a/fix-soname-ld-library-path.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From a5d2b7cf73540f723f4ec30fd18803fbb258a5ff Mon Sep 17 00:00:00 2001
-From: Jonathon Reinhart <Jonathon.Reinhart@gmail.com>
-Date: Sat, 17 Oct 2015 08:53:49 -0400
-Subject: [PATCH] tests: create libunicorn.so.0 symlink
-
-This hack allows the unit tests to link against libunicorn, after
-the SONAME was added in 4860fdb3.
-
-Becuase libunicorn.so has an SONAME of libunicorn.so.0, the linker uses
-the SONAME for the DT_NEEDED entry of the tests. But because a library
-with that name does not exist, they would fail to run. This symlink
-works around that issue, without touching the toplevel Makefile.
----
- tests/unit/.gitignore | 2 ++
- tests/unit/Makefile | 5 ++++-
- 2 files changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/tests/unit/.gitignore b/tests/unit/.gitignore
-index 39d66b1..7a2c8b3 100644
---- a/tests/unit/.gitignore
-+++ b/tests/unit/.gitignore
-@@ -1,3 +1,5 @@
- test_x86
- test_mem_map
- test_sanity
-+*.so
-+*.so.*
-diff --git a/tests/unit/Makefile b/tests/unit/Makefile
-index ae66d08..fe0e58f 100644
---- a/tests/unit/Makefile
-+++ b/tests/unit/Makefile
-@@ -14,7 +14,7 @@ clean:
- rm -rf ${ALL_TESTS}
-
- .PHONY: test
--test: export LD_LIBRARY_PATH=../../
-+test: export LD_LIBRARY_PATH=.
- test: ${ALL_TESTS}
- ./test_sanity
- ./test_x86
-@@ -23,9 +23,12 @@ test: ${ALL_TESTS}
- test_sanity: test_sanity.c
- test_x86: test_x86.c
- test_mem_map: test_mem_map.c
-+${ALL_TESTS}: libunicorn.so.0
-
- ${ALL_TESTS}:
- gcc ${CFLAGS} -o $@ $^
-
-+libunicorn.so.0:
-+ ln -s ../../libunicorn.so $@
-
-