summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsaruman92020-05-13 10:46:51 +0300
committersaruman92020-05-13 10:46:51 +0300
commit348be00ec5d158961b4f082d5aa805aae5e256f8 (patch)
treef08862d57d4c99e4e746b0cae0c70517535a1db8
parent2178fb312f6ca7d0764c9860f3b5055492b0d212 (diff)
downloadaur-348be00ec5d158961b4f082d5aa805aae5e256f8.tar.gz
Delete python flags for qemu, add dependencies for python
See https://github.com/unicorn-engine/unicorn/commit/00bbe2ce7d06895084036026b85539975a8e7b26 for details about python flags for qemu. Add python{,2}-setuptools as dependency because unicorn's binding use it.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c08896cb3661..fab86222cb7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = unicorn-git
pkgdesc = Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
- pkgver = 1.0.2.rc1.r5.g3b17db0d
+ pkgver = 1.0.2.rc3.r54.g94c94cdf
pkgrel = 1
url = http://www.unicorn-engine.org
arch = i686
@@ -25,12 +25,14 @@ pkgname = unicorn-git
pkgname = python-unicorn-git
depends = python
depends = unicorn
+ depends = python-setuptools
provides = python-unicorn
conflicts = python-unicorn
pkgname = python2-unicorn-git
depends = python2
depends = unicorn
+ depends = python2-setuptools
provides = python2-unicorn
conflicts = python2-unicorn
diff --git a/PKGBUILD b/PKGBUILD
index 560cbac1c0ba..c5f36026060b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=unicorn-git
pkgname=('unicorn-git' 'python-unicorn-git' 'python2-unicorn-git' 'ruby-unicorn-git')
-pkgver=1.0.2.rc1.r5.g3b17db0d
+pkgver=1.0.2.rc3.r54.g94c94cdf
pkgrel=1
pkgdesc='Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU'
url='http://www.unicorn-engine.org'
@@ -30,7 +30,7 @@ prepare() {
build() {
cd ${pkgbase}
- make UNICORN_QEMU_FLAGS="--python=/usr/bin/python2"
+ make
(cd bindings
python const_generator.py python
python const_generator.py ruby
@@ -63,7 +63,7 @@ package_unicorn-git() {
}
package_python-unicorn-git() {
- depends=('python' 'unicorn')
+ depends=('python' 'unicorn' 'python-setuptools')
provides=('python-unicorn')
conflicts=('python-unicorn')
cd ${pkgbase}/bindings/python
@@ -72,7 +72,7 @@ package_python-unicorn-git() {
}
package_python2-unicorn-git() {
- depends=('python2' 'unicorn')
+ depends=('python2' 'unicorn' 'python2-setuptools')
provides=('python2-unicorn')
conflicts=('python2-unicorn')
cd ${pkgbase}/bindings/python2