summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornullableVoidPtr2022-03-09 16:26:07 +0800
committernullableVoidPtr2022-03-09 16:26:07 +0800
commit8e390f7c0343b9d0f81f802214fa197ae03e0b5c (patch)
tree9e8e6a778020a8b34611434398ef96347f857e57
parent348be00ec5d158961b4f082d5aa805aae5e256f8 (diff)
downloadaur-8e390f7c0343b9d0f81f802214fa197ae03e0b5c.tar.gz
Update to Unicorn2
Fix build to cmake Remove unsupported Py2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 13 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fab86222cb7c..6ab8d511da3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = unicorn-git
pkgdesc = Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU
- pkgver = 1.0.2.rc3.r54.g94c94cdf
+ pkgver = 2.0.0.rc6.r0.gc10639fd
pkgrel = 1
url = http://www.unicorn-engine.org
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = cmake
makedepends = python
- makedepends = python2
makedepends = python-setuptools
- makedepends = python2-setuptools
makedepends = ruby
options = staticlibs
options = !emptydirs
@@ -29,16 +28,8 @@ pkgname = python-unicorn-git
provides = python-unicorn
conflicts = python-unicorn
-pkgname = python2-unicorn-git
- depends = python2
- depends = unicorn
- depends = python2-setuptools
- provides = python2-unicorn
- conflicts = python2-unicorn
-
pkgname = ruby-unicorn-git
depends = ruby
depends = unicorn
provides = ruby-unicorn
conflicts = ruby-unicorn
-
diff --git a/PKGBUILD b/PKGBUILD
index c5f36026060b..d2e48d40760d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Alex Sarum <rum.274.4 at gmail dot com>
+# Maintainer: nullableVoidPtr <nullableVoidPtr _ gmail _ com>
+# Contributor: Alex Sarum <rum.274.4 at gmail dot com>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgbase=unicorn-git
-pkgname=('unicorn-git' 'python-unicorn-git' 'python2-unicorn-git' 'ruby-unicorn-git')
-pkgver=1.0.2.rc3.r54.g94c94cdf
+pkgname=('unicorn-git' 'python-unicorn-git' 'ruby-unicorn-git')
+pkgver=2.0.0.rc6.r0.gc10639fd
pkgrel=1
pkgdesc='Lightweight, multi-platform, multi-architecture CPU emulator framework based on QEMU'
url='http://www.unicorn-engine.org'
arch=('i686' 'x86_64')
license=('GPL2')
-makedepends=('git' 'python' 'python2' 'python-setuptools' 'python2-setuptools' 'ruby')
+makedepends=('git' 'cmake' 'python' 'python-setuptools' 'ruby')
options=('staticlibs' '!emptydirs')
source=(${pkgbase}::git+https://github.com/unicorn-engine/unicorn)
sha512sums=('SKIP')
@@ -19,18 +20,13 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd ${pkgbase}
- sed 's|-O3|-O2|g' -i Makefile qemu/configure
- sed 's|-g ||g' -i qemu/configure
- sed 's|UNICORN_DEBUG ?= yes|UNICORN_DEBUG ?= no|g' -i config.mk
- cp -ra bindings/python{,2}
- sed -r 's|(python)$|\12|' -i bindings/python2/*.py
-}
-
build() {
cd ${pkgbase}
- make
+ (mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+ make
+ )
(cd bindings
python const_generator.py python
python const_generator.py ruby
@@ -38,9 +34,6 @@ build() {
(cd bindings/python
python setup.py build
)
- (cd bindings/python2
- python2 setup.py build
- )
(cd bindings/ruby/unicorn_gem
gem build unicorn-engine.gemspec
)
@@ -71,21 +64,12 @@ package_python-unicorn-git() {
install -Dm 644 sample* shellcode.py -t "${pkgdir}/usr/share/doc/${pkgname}/samples"
}
-package_python2-unicorn-git() {
- depends=('python2' 'unicorn' 'python2-setuptools')
- provides=('python2-unicorn')
- conflicts=('python2-unicorn')
- cd ${pkgbase}/bindings/python2
- python2 setup.py install --root="${pkgdir}" -O1 --skip-build
- install -Dm 644 sample* shellcode.py -t "${pkgdir}/usr/share/doc/${pkgname}/samples"
-}
-
package_ruby-unicorn-git() {
depends=('ruby' 'unicorn')
provides=('ruby-unicorn')
conflicts=('ruby-unicorn')
cd ${pkgbase}/bindings/ruby/unicorn_gem
- local _gemdir="$(gem env gemdir)"
+ local _gemdir="$(ruby -e 'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "${pkgdir}${_gemdir}" \
-n "${pkgdir}/usr/bin" unicorn-*.gem -- --with-opt-include="${srcdir}/${pkgbase}/include"
rm -r "${pkgdir}/${_gemdir}"/{cache/unicorn-*.gem,build_info}